summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-05-10 10:19:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-05-10 10:24:34 +0200
commitbd4a97cb167b7ecfc1c03dba27506ad228b18925 (patch)
tree58c3d80e8a6c74d5f40bb8866fd16f7b891ea831 /sys-devel
parentx11-terms/kitty: remove duplicate .patch file (diff)
downloadgentoo-bd4a97cb167b7ecfc1c03dba27506ad228b18925.tar.gz
gentoo-bd4a97cb167b7ecfc1c03dba27506ad228b18925.tar.bz2
gentoo-bd4a97cb167b7ecfc1c03dba27506ad228b18925.zip
sys-devel/m4: Bump to version 1.4.19_beta1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/m4/Manifest1
-rw-r--r--sys-devel/m4/m4-1.4.19_beta1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-devel/m4/Manifest b/sys-devel/m4/Manifest
index b703cf937046..5ba5a0bac196 100644
--- a/sys-devel/m4/Manifest
+++ b/sys-devel/m4/Manifest
@@ -1 +1,2 @@
DIST m4-1.4.18.tar.xz 1207688 BLAKE2B debfaa4d25af6f583e2cd703e77b73775790f48f34e878eddd820c6b244a065c69495473ce5067be1f20ca07b2d6af9f90cffd33e12c18fd719c0d234eb5462a SHA512 06f583efc3855cd8477d8347544f4ae5153a3e50aea74d21968afa7214784ea3ddfc02d0a2b11324120d76a19f2e804d20de11a456b5da929eb6ae469519b174
+DIST m4-1.4.18b.tar.xz 1541748 BLAKE2B f5d87a58bc8313fd3cb8f28f7e9a6f885d8a4ae2514f2ec16e56fceaf4b147b9812cca16be56b306a385a843aade08bad521ee739e7222157da8ff14567639bb SHA512 febdc35fb41b0277825aaa6d27bd8dcd0cbd4ae5e891d4867b5f142e51ed90663e2fd9ac75312453e3e647a274902cca907d67f514b84ee78cdebe2880156360
diff --git a/sys-devel/m4/m4-1.4.19_beta1.ebuild b/sys-devel/m4/m4-1.4.19_beta1.ebuild
new file mode 100644
index 000000000000..cf3d10dfd14a
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.19_beta1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-1.4.18b"
+
+DESCRIPTION="GNU macro processor"
+HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
+if [[ "${PV}" == *_beta* ]] ; then
+ #SRC_URI="mirror://gnu-alpha/${PN}/${MY_P}.tar.xz"
+ SRC_URI="https://alpha.gnu.org/gnu/${PN}/${MY_P}.tar.xz"
+ S="${WORKDIR}/${MY_P}"
+else
+ SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+# remember: cannot dep on autoconf since it needs us
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ local -a myeconfargs=(
+ --enable-changeword
+
+ # Disable automagic dependency over libsigsegv; see bug #278026
+ ac_cv_libsigsegv=no
+ )
+
+ [[ ${USERLAND} != GNU ]] && myeconfargs+=( --program-prefix=g )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ [[ -d /none ]] && die "m4 tests will fail with /none/" #244396
+ emake check
+}
+
+src_install() {
+ default
+ # autoconf-2.60 for instance, first checks gm4, then m4. If we don't have
+ # gm4, it might find gm4 from outside the prefix on for instance Darwin
+ use prefix && dosym m4 /usr/bin/gm4
+ if use examples ; then
+ dodoc -r examples
+ rm -f "${ED}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+}