summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-30 10:44:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-30 11:01:24 +0100
commitbe1a2f5ffa03322dcc62c80d951a5dbf14545efc (patch)
tree750d39ae008e4e74b898480bba591997dea93467 /sys-devel
parentsys-libs/libomp: Bump to 13.0.1_rc1 (diff)
downloadgentoo-be1a2f5ffa03322dcc62c80d951a5dbf14545efc.tar.gz
gentoo-be1a2f5ffa03322dcc62c80d951a5dbf14545efc.tar.bz2
gentoo-be1a2f5ffa03322dcc62c80d951a5dbf14545efc.zip
sys-devel/clang-runtime: Bump to 13.0.1_rc1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-13.0.1_rc1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-13.0.1_rc1.ebuild b/sys-devel/clang-runtime/clang-runtime-13.0.1_rc1.ebuild
new file mode 100644
index 000000000000..218cdb1426f6
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-13.0.1_rc1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"