summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-09 21:48:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-09 21:48:37 +0200
commitc273403f0950cbaaea87ddf9eeef78ee56742371 (patch)
tree19696bd5171f9dba1d475a957e35cedf2906c3f6 /sys-devel
parentvirtual/dist-kernel: Stabilize 5.4.217 ppc64, #876259 (diff)
downloadgentoo-c273403f0950cbaaea87ddf9eeef78ee56742371.tar.gz
gentoo-c273403f0950cbaaea87ddf9eeef78ee56742371.tar.bz2
gentoo-c273403f0950cbaaea87ddf9eeef78ee56742371.zip
sys-devel/clang-common: Move common config into gentoo-common.cfg
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-15.0.2-r1.ebuild (renamed from sys-devel/clang-common/clang-common-15.0.2.ebuild)9
-rw-r--r--sys-devel/clang-common/clang-common-15.0.2.9999.ebuild9
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0.9999.ebuild9
-rw-r--r--sys-devel/clang-common/clang-common-16.0.0_pre20221006-r1.ebuild (renamed from sys-devel/clang-common/clang-common-16.0.0_pre20221006.ebuild)9
4 files changed, 28 insertions, 8 deletions
diff --git a/sys-devel/clang-common/clang-common-15.0.2.ebuild b/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
index 71e8aa15b6d8..9962f257ccc0 100644
--- a/sys-devel/clang-common/clang-common-15.0.2.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.2-r1.ebuild
@@ -76,12 +76,17 @@ src_install() {
# It is used to specify the selected GCC installation.
EOF
+ newins - gentoo-common.cfg <<-EOF
+ # This file contains flags common to clang, clang++ and clang-cpp.
+ @gentoo-runtimes.cfg
+ @gentoo-gcc-install.cfg
+ EOF
+
local tool
for tool in clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
- @gentoo-runtimes.cfg
- @gentoo-gcc-install.cfg
+ @gentoo-common.cfg
EOF
done
}
diff --git a/sys-devel/clang-common/clang-common-15.0.2.9999.ebuild b/sys-devel/clang-common/clang-common-15.0.2.9999.ebuild
index e318815568c5..0ff52691cc71 100644
--- a/sys-devel/clang-common/clang-common-15.0.2.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-15.0.2.9999.ebuild
@@ -75,12 +75,17 @@ src_install() {
# It is used to specify the selected GCC installation.
EOF
+ newins - gentoo-common.cfg <<-EOF
+ # This file contains flags common to clang, clang++ and clang-cpp.
+ @gentoo-runtimes.cfg
+ @gentoo-gcc-install.cfg
+ EOF
+
local tool
for tool in clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
- @gentoo-runtimes.cfg
- @gentoo-gcc-install.cfg
+ @gentoo-common.cfg
EOF
done
}
diff --git a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
index e318815568c5..0ff52691cc71 100644
--- a/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0.9999.ebuild
@@ -75,12 +75,17 @@ src_install() {
# It is used to specify the selected GCC installation.
EOF
+ newins - gentoo-common.cfg <<-EOF
+ # This file contains flags common to clang, clang++ and clang-cpp.
+ @gentoo-runtimes.cfg
+ @gentoo-gcc-install.cfg
+ EOF
+
local tool
for tool in clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
- @gentoo-runtimes.cfg
- @gentoo-gcc-install.cfg
+ @gentoo-common.cfg
EOF
done
}
diff --git a/sys-devel/clang-common/clang-common-16.0.0_pre20221006.ebuild b/sys-devel/clang-common/clang-common-16.0.0_pre20221006-r1.ebuild
index e318815568c5..0ff52691cc71 100644
--- a/sys-devel/clang-common/clang-common-16.0.0_pre20221006.ebuild
+++ b/sys-devel/clang-common/clang-common-16.0.0_pre20221006-r1.ebuild
@@ -75,12 +75,17 @@ src_install() {
# It is used to specify the selected GCC installation.
EOF
+ newins - gentoo-common.cfg <<-EOF
+ # This file contains flags common to clang, clang++ and clang-cpp.
+ @gentoo-runtimes.cfg
+ @gentoo-gcc-install.cfg
+ EOF
+
local tool
for tool in clang{,++,-cpp}; do
newins - "${tool}.cfg" <<-EOF
# This configuration file is used by ${tool} driver.
- @gentoo-runtimes.cfg
- @gentoo-gcc-install.cfg
+ @gentoo-common.cfg
EOF
done
}