summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-30 07:23:56 +0100
committerSam James <sam@gentoo.org>2022-05-30 07:29:21 +0100
commitc4973cd064a63372fb5c107315673adb9b089499 (patch)
treef29e24572f6919cc6b89efb19bab5f79d5523af3 /sys-devel
parentsys-devel/binutils: sync output; more verbose logs (diff)
downloadgentoo-c4973cd064a63372fb5c107315673adb9b089499.tar.gz
gentoo-c4973cd064a63372fb5c107315673adb9b089499.tar.bz2
gentoo-c4973cd064a63372fb5c107315673adb9b089499.zip
sys-devel/binutils-hppa64: sync output; more verbose logs
See: 2619d10984d0633e8cab4464c389ba9cc10642cb Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild
index cfb3450416da..b6e72448d384 100644
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.38-r2.ebuild
@@ -151,6 +151,11 @@ toolchain-binutils_pkgversion() {
}
src_configure() {
+ # See https://www.gnu.org/software/make/manual/html_node/Parallel-Output.html
+ # Avoid really confusing logs from subconfigure spam, makes logs far
+ # more legible.
+ MAKEOPTS="--output-sync=line ${MAKEOPTS}"
+
# Setup some paths
LIBPATH=/usr/$(get_libdir)/binutils/${CTARGET}/${PV}
INCPATH=${LIBPATH}/include
@@ -294,11 +299,11 @@ src_compile() {
cd "${MY_BUILDDIR}" || die
# see Note [tooldir hack for ldscripts]
- emake tooldir="${EPREFIX}${TOOLPATH}" all
+ emake V=1 tooldir="${EPREFIX}${TOOLPATH}" all
# only build info pages if the user wants them
if use doc ; then
- emake info
+ emake V=1 info
fi
# we nuke the manpages when we're left with junk
@@ -312,7 +317,7 @@ src_test() {
# bug #637066
filter-flags -Wall -Wreturn-type
- emake -k check
+ emake -k V=1 check
}
src_install() {
@@ -321,7 +326,7 @@ src_install() {
cd "${MY_BUILDDIR}" || die
# see Note [tooldir hack for ldscripts]
- emake DESTDIR="${D}" tooldir="${EPREFIX}${LIBPATH}" install
+ emake V=1 DESTDIR="${D}" tooldir="${EPREFIX}${LIBPATH}" install
rm -rf "${ED}"/${LIBPATH}/bin || die
use static-libs || find "${ED}" -name '*.la' -delete