summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-09 15:32:17 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-09 15:34:39 +0100
commitd228da4ab9e46092f1a65b1fd7d1ad7a6c0f46e7 (patch)
treefc0f0b7fa11667e67853922ee553e149d0402284 /sys-devel
parentdev-ml/llvm-ocaml: Disable experimental targets on the release branch (diff)
downloadgentoo-d228da4ab9e46092f1a65b1fd7d1ad7a6c0f46e7.tar.gz
gentoo-d228da4ab9e46092f1a65b1fd7d1ad7a6c0f46e7.tar.bz2
gentoo-d228da4ab9e46092f1a65b1fd7d1ad7a6c0f46e7.zip
sys-devel/llvm: Remove experimental targets from the release branch
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-6.0.9999.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/sys-devel/llvm/llvm-6.0.9999.ebuild b/sys-devel/llvm/llvm-6.0.9999.ebuild
index 0164813c3fc0..c349ca3d09a4 100644
--- a/sys-devel/llvm/llvm-6.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-6.0.9999.ebuild
@@ -18,12 +18,9 @@ EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
https://github.com/llvm-mirror/llvm.git"
EGIT_BRANCH="release_60"
-# Those are in lib/Targets, without explicit CMakeLists.txt mention
-ALL_LLVM_EXPERIMENTAL_TARGETS=( AVR Nios2 RISCV WebAssembly )
# Keep in sync with CMakeLists.txt
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore
- "${ALL_LLVM_EXPERIMENTAL_TARGETS[@]}" )
+ NVPTX PowerPC Sparc SystemZ X86 XCore )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
# Additional licenses:
@@ -102,10 +99,7 @@ multilib_src_configure() {
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-DBUILD_SHARED_LIBS=ON
- # cheap hack: LLVM combines both anyway, and the only difference
- # is that the former list is explicitly verified at cmake time
- -DLLVM_TARGETS_TO_BUILD=""
- -DLLVM_EXPERIMENTAL_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
-DLLVM_BUILD_TESTS=$(usex test)
-DLLVM_ENABLE_FFI=$(usex libffi)