summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-15 22:36:28 +0000
committerSam James <sam@gentoo.org>2023-01-15 22:40:12 +0000
commite958d4fadbead2caac9181c80d89ae58b4252890 (patch)
tree95c5c4e10d8c2cf7161468df1d59706dffd0917c /sys-devel
parentsys-devel/crossdev: drop 20221227-r1 (diff)
downloadgentoo-e958d4fadbead2caac9181c80d89ae58b4252890.tar.gz
gentoo-e958d4fadbead2caac9181c80d89ae58b4252890.tar.bz2
gentoo-e958d4fadbead2caac9181c80d89ae58b4252890.zip
sys-devel/gcc-config: drop 2.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/Manifest1
-rw-r--r--sys-devel/gcc-config/gcc-config-2.9.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/sys-devel/gcc-config/Manifest b/sys-devel/gcc-config/Manifest
index 667843224c00..ba7fe333bdac 100644
--- a/sys-devel/gcc-config/Manifest
+++ b/sys-devel/gcc-config/Manifest
@@ -1,3 +1,2 @@
DIST gcc-config-2.10.tar.xz 18040 BLAKE2B de902fcf9169290a09988b56fa75f1bf24f702ce98a8fe37b6d4fe090bab615716c32a9e219d25a2257c60099eb4424b86cc1a1565c1b4f3dbcd6c9acad6f340 SHA512 cced56c52d97cbace5fb7e1fc9c73b413454bc5c53641c9429a7da88a0b31db2c70a8b90a4b4b0fbe1e732f21a5f979a4721a7bc8537666f8277b7755bd4af52
DIST gcc-config-2.8.tar.xz 17968 BLAKE2B aa34e681ef0c86bb846d89b816b46276f5c7c32974c785a9611a903a4fe165c997a34664abe17aa4d8720a96f194054e5d8c371a6c9270b1c235d7539094436c SHA512 5e91df44fb7782b9ad41ed06fbd53f74868c059f892c6c2b8195ebaa899905dd9f502562887f1a3765dd6b61698e956d01c6fa6f97a535cf16e26e70fcd902ba
-DIST gcc-config-2.9.tar.xz 18032 BLAKE2B 6ee4d89a7fc2c211cb2ce0f6b0802ac300b30deccf6e54cd80a548d6e2e878097ad93cb0174485df8611780cf29e0c3c7590f726409f369a92c6d780db5c167f SHA512 11fa782699ffcca38eee9ef3ca8dbdfdda68459bdad80ca3378ae07e0ee7c114a494c3362e05dc39d69d9770808f2b97bc682aec49e3c3483e7ba0c4498d57f3
diff --git a/sys-devel/gcc-config/gcc-config-2.9.ebuild b/sys-devel/gcc-config/gcc-config-2.9.ebuild
deleted file mode 100644
index 7ff12f007e38..000000000000
--- a/sys-devel/gcc-config/gcc-config-2.9.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
- inherit git-r3
-else
- SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-DESCRIPTION="Utility to manage compilers"
-HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+cc-wrappers +native-symlinks"
-
-RDEPEND=">=sys-apps/gentoo-functions-0.10"
-
-_emake() {
- emake \
- PV="${PVR}" \
- SUBLIBDIR="$(get_libdir)" \
- USE_CC_WRAPPERS="$(usex cc-wrappers)" \
- USE_NATIVE_LINKS="$(usex native-symlinks)" \
- TOOLCHAIN_PREFIX="${CHOST}-" \
- "$@"
-}
-
-src_compile() {
- _emake
-}
-
-src_install() {
- _emake DESTDIR="${D}" install
-}
-
-pkg_postinst() {
- # Do we have a valid multi ver setup ?
- local x
- for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
- gcc-config ${x}
- done
-
- # USE flag change can add or delete files in /usr/bin worth recaching
- if [[ ! ${ROOT} && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
- eselect compiler-shadow update all
- fi
-
- if ! has_version "sys-devel/gcc[gcj(-)]" && [[ -x "${EROOT}"/usr/bin/gcj ]] ; then
- # Warn about obsolete /usr/bin/gcj for bug #804178
- ewarn "Obsolete GCJ wrapper found: ${EROOT}/usr/bin/gcj!"
- ewarn "Please delete this file unless you know it is needed (e.g. custom gcj install)."
- ewarn "If you have no idea what this means, please delete the file:"
- ewarn " rm ${EROOT}/usr/bin/gcj"
- fi
-}