summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-08-20 09:25:05 +0100
committerMatthew Smith <matthew@gentoo.org>2022-08-20 09:26:11 +0100
commiteaf1cdafeb5bfea797ebbad795b848f48a86a5f2 (patch)
treebda2fe4845d21ba309235cd27146bbac85c58b4a /sys-devel
parentdev-libs/apr: apply fix for CVE-2021-35940 (diff)
downloadgentoo-eaf1cdafeb5bfea797ebbad795b848f48a86a5f2.tar.gz
gentoo-eaf1cdafeb5bfea797ebbad795b848f48a86a5f2.tar.bz2
gentoo-eaf1cdafeb5bfea797ebbad795b848f48a86a5f2.zip
sys-devel/mold: stop calling python during build
Closes: https://bugs.gentoo.org/865859 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/mold/mold-1.4.1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-devel/mold/mold-1.4.1.ebuild b/sys-devel/mold/mold-1.4.1.ebuild
index 804483084d56..ff42b7ccf9f9 100644
--- a/sys-devel/mold/mold-1.4.1.ebuild
+++ b/sys-devel/mold/mold-1.4.1.ebuild
@@ -71,9 +71,13 @@ src_prepare() {
rm test/elf/{,ifunc-}static-pie.sh || die
fi
- # Don't require python
- sed -i '/find_package(Python3/d' CMakeLists.txt || die
- sed -i '/add_dependencies/d' CMakeLists.txt || die
+ # Don't require python. The next release has this script rewritten
+ # in CMake and so this can be dropped.
+ sed -e '/find_package(Python3/d' \
+ -e '/add_dependencies/d' \
+ -e '/UpdateGitHash/,/)/d' \
+ -i CMakeLists.txt || die
+ rm update-git-hash.py || die
cat <<EOF>git-hash.cc
#include <string>
namespace mold {