summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-07-09 01:23:25 +0200
committerMichał Górny <mgorny@gentoo.org>2017-07-09 01:24:42 +0200
commitfc547872f97d89e67987ee909deacde980f2dfd1 (patch)
tree2c8ad53b0670de9009032c5e43fa2d913e8b7805 /sys-devel
parentdev-python/lit: Use https for llvm.org (diff)
downloadgentoo-fc547872f97d89e67987ee909deacde980f2dfd1.tar.gz
gentoo-fc547872f97d89e67987ee909deacde980f2dfd1.tar.bz2
gentoo-fc547872f97d89e67987ee909deacde980f2dfd1.zip
sys-devel/llvm: Use https for llvm.org
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/llvm-3.4.2-r100.ebuild8
-rw-r--r--sys-devel/llvm/llvm-3.5.2-r100.ebuild8
-rw-r--r--sys-devel/llvm/llvm-3.6.2-r100.ebuild8
-rw-r--r--sys-devel/llvm/llvm-3.7.1-r3.ebuild14
-rw-r--r--sys-devel/llvm/llvm-3.8.1-r2.ebuild12
-rw-r--r--sys-devel/llvm/llvm-3.9.1-r1.ebuild12
-rw-r--r--sys-devel/llvm/llvm-4.0.0-r2.ebuild4
-rw-r--r--sys-devel/llvm/llvm-4.0.1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild2
9 files changed, 36 insertions, 36 deletions
diff --git a/sys-devel/llvm/llvm-3.4.2-r100.ebuild b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
index d03486db7d73..c533ef6f68e8 100644
--- a/sys-devel/llvm/llvm-3.4.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.4.2-r100.ebuild
@@ -8,10 +8,10 @@ inherit eutils check-reqs flag-o-matic multilib pax-utils prefix \
python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.gz
- clang? ( http://llvm.org/releases/3.4/compiler-rt-3.4.src.tar.gz
- http://llvm.org/releases/${PV}/cfe-${PV}.src.tar.gz )
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.gz
+ clang? ( https://llvm.org/releases/3.4/compiler-rt-3.4.src.tar.gz
+ https://llvm.org/releases/${PV}/cfe-${PV}.src.tar.gz )
https://dev.gentoo.org/~mgorny/dist/llvm/${PN}-3.4-manpages.tar.bz2
https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.gz"
diff --git a/sys-devel/llvm/llvm-3.5.2-r100.ebuild b/sys-devel/llvm/llvm-3.5.2-r100.ebuild
index 07457902436e..fc7b03e22ba8 100644
--- a/sys-devel/llvm/llvm-3.5.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2-r100.ebuild
@@ -8,10 +8,10 @@ inherit eutils check-reqs flag-o-matic multilib pax-utils prefix \
python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
- clang? ( http://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
- http://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz )
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz
+ clang? ( https://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
+ https://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz )
https://dev.gentoo.org/~voyageur/distfiles/${PN}-3.5.0-manpages.tar.bz2
https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.gz"
diff --git a/sys-devel/llvm/llvm-3.6.2-r100.ebuild b/sys-devel/llvm/llvm-3.6.2-r100.ebuild
index aedeb8346987..c84af618ae08 100644
--- a/sys-devel/llvm/llvm-3.6.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.6.2-r100.ebuild
@@ -8,10 +8,10 @@ inherit eutils check-reqs flag-o-matic multilib pax-utils prefix \
python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
- clang? ( http://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
- http://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz )
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz
+ clang? ( https://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
+ https://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz )
https://dev.gentoo.org/~voyageur/distfiles/${PN}-3.6.1-manpages.tar.bz2
https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.gz"
diff --git a/sys-devel/llvm/llvm-3.7.1-r3.ebuild b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
index 5e3be43913a3..a443825a626c 100644
--- a/sys-devel/llvm/llvm-3.7.1-r3.ebuild
+++ b/sys-devel/llvm/llvm-3.7.1-r3.ebuild
@@ -10,12 +10,12 @@ inherit check-reqs cmake-utils eutils flag-o-matic multilib \
multilib-minimal python-single-r1 toolchain-funcs pax-utils prefix
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
- clang? ( http://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
- http://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz
- http://llvm.org/releases/${PV}/clang-tools-extra-${PV}.src.tar.xz )
- lldb? ( http://llvm.org/releases/${PV}/lldb-${PV}.src.tar.xz )
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz
+ clang? ( https://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
+ https://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz
+ https://llvm.org/releases/${PV}/clang-tools-extra-${PV}.src.tar.xz )
+ lldb? ( https://llvm.org/releases/${PV}/lldb-${PV}.src.tar.xz )
!doc? ( https://dev.gentoo.org/~voyageur/distfiles/${PN}-3.7.0-manpages.tar.bz2 )
https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.gz"
@@ -253,7 +253,7 @@ src_prepare() {
-i tools/lldb/scripts/Python/finishSwigPythonLLDB.py || die
# Fix build with ncurses[tinfo], #560474
- # http://llvm.org/viewvc/llvm-project?view=revision&revision=247842
+ # https://llvm.org/viewvc/llvm-project?view=revision&revision=247842
eapply "${WORKDIR}/${P}-patchset"/lldb/tinfo.patch
fi
diff --git a/sys-devel/llvm/llvm-3.8.1-r2.ebuild b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
index e1df41fb8a4f..e6e60425a190 100644
--- a/sys-devel/llvm/llvm-3.8.1-r2.ebuild
+++ b/sys-devel/llvm/llvm-3.8.1-r2.ebuild
@@ -10,12 +10,12 @@ inherit check-reqs cmake-utils eutils flag-o-matic multilib \
multilib-minimal python-single-r1 toolchain-funcs pax-utils prefix
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
- clang? ( http://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
- http://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz
- http://llvm.org/releases/${PV}/clang-tools-extra-${PV}.src.tar.xz )
- lldb? ( http://llvm.org/releases/${PV}/lldb-${PV}.src.tar.xz )
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz
+ clang? ( https://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
+ https://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz
+ https://llvm.org/releases/${PV}/clang-tools-extra-${PV}.src.tar.xz )
+ lldb? ( https://llvm.org/releases/${PV}/lldb-${PV}.src.tar.xz )
!doc? ( https://dev.gentoo.org/~voyageur/distfiles/${PN}-3.8.0-manpages.tar.bz2 )
https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.xz"
diff --git a/sys-devel/llvm/llvm-3.9.1-r1.ebuild b/sys-devel/llvm/llvm-3.9.1-r1.ebuild
index b8a917ab13e9..11188e4e124b 100644
--- a/sys-devel/llvm/llvm-3.9.1-r1.ebuild
+++ b/sys-devel/llvm/llvm-3.9.1-r1.ebuild
@@ -10,12 +10,12 @@ inherit check-reqs cmake-utils eutils flag-o-matic multilib \
multilib-minimal python-single-r1 toolchain-funcs pax-utils prefix
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
- clang? ( http://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
- http://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz
- http://llvm.org/releases/${PV}/clang-tools-extra-${PV}.src.tar.xz )
- lldb? ( http://llvm.org/releases/${PV}/lldb-${PV}.src.tar.xz )
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://llvm.org/releases/${PV}/${P}.src.tar.xz
+ clang? ( https://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
+ https://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz
+ https://llvm.org/releases/${PV}/clang-tools-extra-${PV}.src.tar.xz )
+ lldb? ( https://llvm.org/releases/${PV}/lldb-${PV}.src.tar.xz )
!doc? ( https://dev.gentoo.org/~mgorny/dist/llvm/${PN}-3.9.0_rc3-manpages.tar.bz2 )
https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.xz"
diff --git a/sys-devel/llvm/llvm-4.0.0-r2.ebuild b/sys-devel/llvm/llvm-4.0.0-r2.ebuild
index 0ffd1b669de2..8aab227bc914 100644
--- a/sys-devel/llvm/llvm-4.0.0-r2.ebuild
+++ b/sys-devel/llvm/llvm-4.0.0-r2.ebuild
@@ -12,8 +12,8 @@ inherit cmake-utils flag-o-matic multilib-minimal pax-utils \
python-any-r1 toolchain-funcs versionator
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz
!doc? ( https://dev.gentoo.org/~mgorny/dist/llvm-manpages-${PV}.tar.bz2 )"
# Keep in sync with CMakeLists.txt
diff --git a/sys-devel/llvm/llvm-4.0.1.ebuild b/sys-devel/llvm/llvm-4.0.1.ebuild
index e0f1f16e0ff6..0c5bec512cce 100644
--- a/sys-devel/llvm/llvm-4.0.1.ebuild
+++ b/sys-devel/llvm/llvm-4.0.1.ebuild
@@ -12,8 +12,8 @@ inherit cmake-utils flag-o-matic multilib-minimal pax-utils \
python-any-r1 toolchain-funcs versionator
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
-SRC_URI="http://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz
!doc? ( https://dev.gentoo.org/~mgorny/dist/llvm/llvm-manpages-${PV}.tar.bz2 )"
# Keep in sync with CMakeLists.txt
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 9e9b95c1baab..adc0505a80ae 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -12,7 +12,7 @@ inherit cmake-utils flag-o-matic git-r3 multilib-minimal pax-utils \
python-any-r1 toolchain-funcs versionator
DESCRIPTION="Low Level Virtual Machine"
-HOMEPAGE="http://llvm.org/"
+HOMEPAGE="https://llvm.org/"
SRC_URI=""
EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
https://github.com/llvm-mirror/llvm.git"