summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2016-06-29 17:17:07 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2016-06-30 01:31:15 +0300
commit78687b7871a6d19ba23ac5da91c72d9732061bc1 (patch)
treebefa090ead56292b47a1607c1388583318fbbc3e /sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild
parentgames-emulation/dosbox: sync live ebuild and make it copyable (diff)
downloadgentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.tar.gz
gentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.tar.bz2
gentoo-78687b7871a6d19ba23ac5da91c72d9732061bc1.zip
eclass/openib.eclass: Clean up ancient versions
Also move to sys-fabric category
Diffstat (limited to 'sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild')
-rw-r--r--sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild b/sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild
new file mode 100644
index 000000000000..205e3fe83fd1
--- /dev/null
+++ b/sys-fabric/infinipath-psm/infinipath-psm-3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OFED_VER="3.12"
+OFED_RC="1"
+OFED_RC_VER="1"
+OFED_SUFFIX="2_ga8c3e3e_open"
+OFED_SNAPSHOT="1"
+OFED_SRC_SNAPSHOT="1"
+
+inherit openib udev
+
+DESCRIPTION="OpenIB userspace driver for the PathScale InfiniBand HCAs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="sys-fabric/libibverbs:${SLOT}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+block_other_ofed_versions
+
+src_prepare() {
+ sed -e 's:uname -p:uname -m:g' \
+ -e 's:-Werror::g' \
+ -i buildflags.mak || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+ udev_dorules "${FILESDIR}"/42-infinipath-psm.rules
+}