summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2016-04-19 20:25:20 +1000
committerMark Wright <gienah@gentoo.org>2016-04-19 20:25:20 +1000
commit023908bd2e9a4ea80b0b148a967ac88061c2a8e8 (patch)
tree42ca3abeb2d7eec3192a0408c35f38aeb182294c /sys-firmware/iwl7260-ucode/iwl7260-ucode-0.13.30.25.ebuild
parentprofiles: fix mythtv spelling in package.mask (diff)
downloadgentoo-023908bd2e9a4ea80b0b148a967ac88061c2a8e8.tar.gz
gentoo-023908bd2e9a4ea80b0b148a967ac88061c2a8e8.tar.bz2
gentoo-023908bd2e9a4ea80b0b148a967ac88061c2a8e8.zip
sys-firmware/iwl7260-ucode: Bump 12, 13 slots, thanks to Elizabeth Myers.
Bump 12 slot to 0.12.17.25, 13 slot to 0.13.30.25, 16 slot to 0.16.242414, thanks to Elizabeth Myers for 12 and 13 slot ebuilds, and for reporting. Gentoo-bug: 561502 Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-firmware/iwl7260-ucode/iwl7260-ucode-0.13.30.25.ebuild')
-rw-r--r--sys-firmware/iwl7260-ucode/iwl7260-ucode-0.13.30.25.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-firmware/iwl7260-ucode/iwl7260-ucode-0.13.30.25.ebuild b/sys-firmware/iwl7260-ucode/iwl7260-ucode-0.13.30.25.ebuild
new file mode 100644
index 000000000000..d1356d75a0df
--- /dev/null
+++ b/sys-firmware/iwl7260-ucode/iwl7260-ucode-0.13.30.25.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit linux-info versionator
+
+DEV_N="${PN:3:4}"
+vc=($(get_all_version_components "${PV}"))
+MY_PV="${vc[6]}.${vc[4]}.${vc[2]}.${vc[0]}"
+MY_PN="iwlwifi-${DEV_N}-ucode"
+
+DV_MAJOR="4"
+DV_MINOR="1"
+DV_PATCH="0"
+
+DESCRIPTION="Firmware for Intel (R) Dual Band Wireless-AC ${DEV_N}"
+HOMEPAGE="https://wireless.kernel.org/en/users/Drivers/iwlwifi"
+SRC_URI="https://wireless.wiki.kernel.org/_media/en/users/drivers/${MY_PN}-${MY_PV}.tgz -> ${P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="${vc[2]}"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+DEPEND=""
+RDEPEND="bluetooth? ( sys-firmware/iwl3160-7260-bt-ucode )
+ !sys-kernel/linux-firmware[-savedconfig]"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+CONFIG_CHECK="~IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
+
+pkg_pretend() {
+ if kernel_is lt "${DV_MAJOR}" "${DV_MINOR}" "${DV_PATCH}"; then
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ ewarn "This microcode image requires a kernel >= ${DV_MAJOR}.${DV_MINOR}.${DV_PATCH}."
+ ewarn "For kernel versions < ${DV_MAJOR}.${DV_MINOR}.${DV_PATCH}, you may install older SLOTS"
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/iwlwifi-${DEV_N}-${vc[2]}.ucode"
+ dodoc README*
+}