summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2020-12-03 15:24:41 +0100
committerSam James <sam@gentoo.org>2020-12-15 04:07:45 +0000
commit74f787052473457d550b4e076b5c84faa5bbcec6 (patch)
treef402cc9ce19e72c23d53b0c9bc238051675d310a /sys-firmware/raspberrypi-wifi-ucode
parentnet-misc/unison: remove old (diff)
downloadgentoo-74f787052473457d550b4e076b5c84faa5bbcec6.tar.gz
gentoo-74f787052473457d550b4e076b5c84faa5bbcec6.tar.bz2
gentoo-74f787052473457d550b4e076b5c84faa5bbcec6.zip
sys-firmware/raspberrypi-wifi-ucode: Bump to 20190114.1_p10
New firmware for the BCM43456 (Wifi Chip on Raspberry PI CM4) Untested, since the good CM4s are sold out everywhere. Changelog: firmware-nonfree (1:20190114-1+rpt10) buster; urgency=medium [ Phil Elwell ] * New clm_blob for BCM43456 - An updated clm_blob to open up the 80MHz channels. * Use BCM43456 clm_blob on CYW43455 - The previous CYW43455 clm_blob provides limited access to the higher 5GHz channels (100+) - the BCM43456 (surprisingly) seems to work and doesn't have this problem. -- Serge Schneider <serge@raspberrypi.com> Thu, 26 Nov 2020 18:51:42 +0000 Closes: https://bugs.gentoo.org/758278 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/18489 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-firmware/raspberrypi-wifi-ucode')
-rw-r--r--sys-firmware/raspberrypi-wifi-ucode/Manifest1
-rw-r--r--sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20190114.1_p10.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-firmware/raspberrypi-wifi-ucode/Manifest b/sys-firmware/raspberrypi-wifi-ucode/Manifest
index 7e0c1fe7bcf9..37af51d68ce8 100644
--- a/sys-firmware/raspberrypi-wifi-ucode/Manifest
+++ b/sys-firmware/raspberrypi-wifi-ucode/Manifest
@@ -1 +1,2 @@
+DIST firmware-nonfree_20190114-1+rpt10.debian.tar.xz 2034132 BLAKE2B f6bdfbedc261acdcef976c02fb96f312a7c16c1c06c9419de73559c6ba59cf7d558b28c0dbf720bef3942a57c512fe8b5066bbb574b8286f9184ab029af9c20d SHA512 cf8eb4ad1947dc9f692fcf6540174a186bb054ea8cfdcd458c98452fa90125fc5079ac1cdfcf4171b6ee97023bc1d0a2a180d4b6ef6829c7c84a84922ee336f6
DIST firmware-nonfree_20190114-1+rpt9.debian.tar.xz 2040560 BLAKE2B 923adb08e4033f1f70c8e373464b5a4881f354fb218b163accb957b99ed1adf104f496b2156c772d881e7e01ed393d0f6c1563dbe797e1b1600a1f7f768292c4 SHA512 80df5df213105bfae231dbc81d17941258063971ea82e5d321b31d92a0be7101b9ecfe03aed02d9b7a0263d13bbcdcb862d4892a9e789da781af1430d81a821d
diff --git a/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20190114.1_p10.ebuild b/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20190114.1_p10.ebuild
new file mode 100644
index 000000000000..38d2b40eea18
--- /dev/null
+++ b/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20190114.1_p10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Most up-to-date uCode for the Broadcom wifi chips on Raspberry Pi SBCs"
+HOMEPAGE="https://github.com/RPi-Distro/firmware-nonfree
+ https://archive.raspberrypi.org/debian/pool/main/f/firmware-nonfree"
+MY_PN=firmware-nonfree
+SRC_URI="https://archive.raspberrypi.org/debian/pool/main/f/${MY_PN}/${MY_PN}_$(ver_cut 1)-$(ver_cut 2)+rpt$(ver_cut 4).debian.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="Broadcom"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
+
+pkg_pretend() {
+ local -a BADFILES=()
+ local txt file
+ # /lib/firmware/brcm/brcmfmac434{30,36,55,56}-sdio.*.txt
+ # The above pattern works because the files we want to hit
+ # have names of the form:
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.AP6212.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.Hampoo-D2D3_Vi8A1.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.MUR1DX.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.MINIX-NEO Z83-4.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-a-plus.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
+ # While the files installed by raspberrypi-wifi-ucode have names
+ # of the form:
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43436-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43456-sdio.txt
+ # So no overlap is assured.
+ for txt in "${EPREFIX}"/lib/firmware/brcm/brcmfmac434{30,36,55,56}-sdio.*.txt; do
+ [[ -e "${txt}" ]] && BADFILES+=( "${txt}" )
+ done
+
+ if [[ "${#BADFILES[@]}" -gt 1 ]]; then
+ eerror "The following files should be excluded from the savedconfig of"
+ eerror "linux-firmware and linux-firmware should be re-emerged. Even"
+ eerror "though they do not collide with files from ${PN},"
+ eerror "they may be loaded preferentially to the files included in"
+ eerror "${PN}, leading to undefined behaviour."
+ eerror "List of files:"
+ for file in "${BADFILES[@]}"; do
+ eerror "${file}"
+ done
+ fi
+}
+
+src_prepare() {
+ default
+ eapply -p1 debian/patches/sdio-txt-files.patch
+}
+
+src_install() {
+ insinto /lib/firmware/brcm
+ doins brcm/*
+ dodoc debian/changelog
+}