summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-01-04 14:23:13 -0500
committerMike Frysinger <vapier@gentoo.org>2016-01-04 14:26:56 -0500
commit9ce92a3e0e039149660f833a9fe470d9dc0eb453 (patch)
treee00fb510bd82976ea04dc32ad5223cc8766a239a /sys-firmware/seabios
parentwww-client/seamonkey: Adopted rpath handling from firefox ebuilds. (diff)
downloadgentoo-9ce92a3e0e039149660f833a9fe470d9dc0eb453.tar.gz
gentoo-9ce92a3e0e039149660f833a9fe470d9dc0eb453.tar.bz2
gentoo-9ce92a3e0e039149660f833a9fe470d9dc0eb453.zip
sys-firmware/seabios: add keywords for everyone #570876
We invert the REQUIRED_USE logic so it forces USE=binary for all non-x86 arches. That way installing binaries works regardless of the architecture.
Diffstat (limited to 'sys-firmware/seabios')
-rw-r--r--sys-firmware/seabios/seabios-1.8.2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-firmware/seabios/seabios-1.8.2.ebuild b/sys-firmware/seabios/seabios-1.8.2.ebuild
index 2c8d4883369a..02b9e6f0fb29 100644
--- a/sys-firmware/seabios/seabios-1.8.2.ebuild
+++ b/sys-firmware/seabios/seabios-1.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,7 @@ if [[ ${PV} = *9999* || ! -z "${EGIT_COMMIT}" ]]; then
EGIT_REPO_URI="git://git.seabios.org/seabios.git"
inherit git-2
else
- KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd"
# Upstream hasn't released a new binary. We snipe ours from Fedora for now.
# http://code.coreboot.org/p/seabios/downloads/get/bios.bin-${PV}.gz
SRC_URI="!binary? ( http://code.coreboot.org/p/seabios/downloads/get/${P}.tar.gz )
@@ -35,14 +35,14 @@ SLOT="0"
IUSE="+binary debug +seavgabios"
REQUIRED_USE="debug? ( !binary )
- ppc? ( binary )
- ppc64? ( binary )"
+ !amd64? ( !x86? ( binary ) )"
+# The amd64/x86 check is needed to workaround #570892.
DEPEND="
- !binary? (
+ amd64? ( x86? ( !binary? (
>=sys-power/iasl-20060912
${PYTHON_DEPS}
- )"
+ ) ) )"
RDEPEND=""
pkg_pretend() {