summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-06-27 03:17:43 -0500
committerMatthias Maier <tamiko@gentoo.org>2021-06-27 03:22:28 -0500
commit57f2a24c4a3a08929d7ed1a232896c329aa05a2c (patch)
tree3642eb7600a372818ced77dfa44d5f4348b925ca /sys-firmware
parentapp-emulation/qemu: pin new firmware versions (diff)
downloadgentoo-57f2a24c4a3a08929d7ed1a232896c329aa05a2c.tar.gz
gentoo-57f2a24c4a3a08929d7ed1a232896c329aa05a2c.tar.bz2
gentoo-57f2a24c4a3a08929d7ed1a232896c329aa05a2c.zip
sys-firmware/vgabios: version bump to 0.8a
* Drop Gentoo-specific patches in favor of two years of upstream development. * Remove QXL and other firmware variatns removed by upstream. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/vgabios/Manifest1
-rw-r--r--sys-firmware/vgabios/vgabios-0.8a.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-firmware/vgabios/Manifest b/sys-firmware/vgabios/Manifest
index f1e63ab4d30c..81497e77a254 100644
--- a/sys-firmware/vgabios/Manifest
+++ b/sys-firmware/vgabios/Manifest
@@ -1,2 +1,3 @@
DIST vgabios-0.7a-fixes-1.tar.bz2 2602 BLAKE2B 68fbd29e6c660dc69ea110e00ff75fc9d14f10bd11b9be89bd373281852a3133c73ee0f2a7ecdf026b29979e4c20bcdbad0baf9f80d013ffeb24dda892725778 SHA512 30992efac011d4b99301960df08cdc69d9503aa6b61feed01fca2c5a910460269d9500650cb394a0737318e977a282c5e0ab613a8b2bc28b9f0c6528a9a77d73
DIST vgabios-0.7a.tgz 1506655 BLAKE2B fb9b99ab385423b4ef103a56de140591556d2f49fffebfdd508a462551b1a9def9d8dc50c947a88ef6d47c43ff62dbe3d97fef969d985c49b9e78671eaefd34e SHA512 35d789b1b39f8f05b757b6c3379a1b2c33dc27b244720471530325f3e215b5f4fa97cfbfc131f813013f4640fe85be912e7b4cb924fa87ed35e68b6966424874
+DIST vgabios-0.8a.tgz 174452 BLAKE2B b8c63d0375a2d08b5e0d55e25844ed8c09066ee3a3582d6be8de84fdac98b59b86e2db764f5b01e29703bf188cee631b84d3807678b2f8452f87b590d06bbf3a SHA512 bc0028ec9ed39659a65b1135d3803a1d1b48a4e2e6622d87a9c85f0c5099bb69602ad51c38f9915420554bce41599d41ac8a333e0502bd17acaa9ee2db70b662
diff --git a/sys-firmware/vgabios/vgabios-0.8a.ebuild b/sys-firmware/vgabios/vgabios-0.8a.ebuild
new file mode 100644
index 000000000000..b6e76ce21a67
--- /dev/null
+++ b/sys-firmware/vgabios/vgabios-0.8a.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="VGA BIOS implementation"
+HOMEPAGE="http://www.nongnu.org/vgabios/"
+SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="binary debug"
+BDEPEND="!binary? ( sys-devel/dev86 )"
+
+src_compile() {
+ if ! use binary ; then
+ emake clean # Necessary to clean up the pre-built pieces
+ emake biossums
+ emake
+ fi
+}
+
+src_install() {
+ insinto /usr/share/vgabios
+
+ # Stock VGABIOS
+ newins VGABIOS-lgpl-latest.bin vgabios.bin
+ use debug && newins VGABIOS-lgpl-latest.debug.bin vgabios.debug.bin
+
+ # Cirrus
+ newins VGABIOS-lgpl-latest.cirrus.bin vgabios-cirrus.bin
+ use debug && newins VGABIOS-lgpl-latest.cirrus.debug.bin \
+ vgabios-cirrus.debug.bin
+
+ # Banshee
+ newins VGABIOS-lgpl-latest.banshee.bin vgabios-banshee.bin
+
+}