summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2016-10-11 21:37:39 +0900
committerAlexis Ballier <aballier@gentoo.org>2016-10-11 16:47:48 +0200
commite1bd456fcf9272cfdeaf542618c6b1f3ce3d1118 (patch)
tree6eb8e704f2281853b01e1abcd5770ad59d798e86 /sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch
parenteclass/freebsd.eclass: added FreeBSD 11.0 support. (diff)
downloadgentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.gz
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.bz2
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.zip
sys-freebsd: bump to 11.0
Diffstat (limited to 'sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch')
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch
new file mode 100644
index 000000000000..d90aa3163dae
--- /dev/null
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-11.0-libsysdecode.patch
@@ -0,0 +1,22 @@
+diff --git a/lib/libsysdecode/Makefile b/lib/libsysdecode/Makefile
+index e3bfe00..51fc5f0 100644
+--- a/lib/libsysdecode/Makefile
++++ b/lib/libsysdecode/Makefile
+@@ -8,7 +8,7 @@ LIB= sysdecode
+ SRCS= errno.c ioctl.c syscallnames.c utrace.c
+ INCS= sysdecode.h
+
+-CFLAGS+= -I${.CURDIR}/../../sys
++CFLAGS+= -I${.CURDIR}/../../sys -I${.CURDIR}
+
+ MAN+= sysdecode.3 \
+ sysdecode_abi_to_freebsd_errno.3 \
+@@ -37,7 +37,7 @@ CFLAGS.gcc+= ${CFLAGS.gcc.${.IMPSRC}}
+
+ ioctl.c: mkioctls
+ env MACHINE=${MACHINE} CPP="${CPP}" \
+- /bin/sh ${.CURDIR}/mkioctls ${DESTDIR}${INCLUDEDIR} > ${.TARGET}
++ /bin/sh ${.CURDIR}/mkioctls ${.CURDIR}/../../include > ${.TARGET}
+
+ beforedepend: ioctl.c
+