summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro@gentoo.gr.jp>2015-11-23 20:56:34 +0900
committerYuta Satoh <nigoro@gentoo.gr.jp>2015-11-23 20:56:34 +0900
commit73a205d7991182e5d2e1f8135b8c1a4b7482ba4e (patch)
tree7a32089bc452d59fcd75694ba690b8a724b4e9b4 /sys-freebsd/freebsd-lib
parentsys-devel/autogen: fix use of hardcoded /tmp paths during build #563352 (diff)
downloadgentoo-73a205d7991182e5d2e1f8135b8c1a4b7482ba4e.tar.gz
gentoo-73a205d7991182e5d2e1f8135b8c1a4b7482ba4e.tar.bz2
gentoo-73a205d7991182e5d2e1f8135b8c1a4b7482ba4e.zip
sys-freebsd: Move use call from global scope to pkg_setup.
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=566522
Diffstat (limited to 'sys-freebsd/freebsd-lib')
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-10.2-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-10.2-r1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-10.2-r1.ebuild
index 1bd3bd1a267c..7168bea50df7 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-10.2-r1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-10.2-r1.ebuild
@@ -32,8 +32,6 @@ EXTRACTONLY="
gnu/
secure/
"
-use build && EXTRACTONLY+="sys/"
-use zfs && EXTRACTONLY+="cddl/"
if [ "${CATEGORY#*cross-}" = "${CATEGORY}" ]; then
RDEPEND="ssl? ( dev-libs/openssl )
@@ -56,7 +54,7 @@ if [ "${CATEGORY#*cross-}" = "${CATEGORY}" ]; then
=sys-freebsd/freebsd-share-${RV}*
>=virtual/libiconv-0-r2"
else
- EXTRACTONLY+="sys/"
+ EXTRACTONLY+="sys/ "
fi
DEPEND="${DEPEND}
@@ -77,6 +75,10 @@ IUSE="atm bluetooth ssl hesiod ipv6 kerberos usb netware
QA_DT_NEEDED="lib/libc.so.7 usr/lib32/libc.so.7"
pkg_setup() {
+ # Add the required source files.
+ use build && EXTRACTONLY+="sys/ "
+ use zfs && EXTRACTONLY+="cddl/ "
+
[ -c /dev/zero ] || \
die "You forgot to mount /dev; the compiled libc would break."