summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuta Satoh <nigoro.dev@gmail.com>2016-10-11 21:37:39 +0900
committerAlexis Ballier <aballier@gentoo.org>2016-10-11 16:47:48 +0200
commite1bd456fcf9272cfdeaf542618c6b1f3ce3d1118 (patch)
tree6eb8e704f2281853b01e1abcd5770ad59d798e86 /sys-freebsd/freebsd-rescue/files
parenteclass/freebsd.eclass: added FreeBSD 11.0 support. (diff)
downloadgentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.gz
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.tar.bz2
gentoo-e1bd456fcf9272cfdeaf542618c6b1f3ce3d1118.zip
sys-freebsd: bump to 11.0
Diffstat (limited to 'sys-freebsd/freebsd-rescue/files')
-rw-r--r--sys-freebsd/freebsd-rescue/files/freebsd-rescue-11.0-rename-libs.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-rescue/files/freebsd-rescue-11.0-rename-libs.patch b/sys-freebsd/freebsd-rescue/files/freebsd-rescue-11.0-rename-libs.patch
new file mode 100644
index 000000000000..31035747a43d
--- /dev/null
+++ b/sys-freebsd/freebsd-rescue/files/freebsd-rescue-11.0-rename-libs.patch
@@ -0,0 +1,22 @@
+diff --git a/rescue/rescue/Makefile b/rescue/rescue/Makefile
+index e747c02..a061436 100644
+--- a/rescue/rescue/Makefile
++++ b/rescue/rescue/Makefile
+@@ -54,7 +54,7 @@ CRUNCH_PROGS_bin= cat chflags chio chmod cp date dd df echo \
+ ed expr getfacl hostname kenv kill ln ls mkdir mv \
+ pkill ps pwd realpath rm rmdir setfacl sh sleep stty \
+ sync test
+-CRUNCH_LIBS+= -lcrypt -ledit -ljail -lkvm -lelf -ll -ltermcapw -lutil -lxo
++CRUNCH_LIBS+= -lcrypt -ledit -ljail -lkvm -lelf -lfl -lncursesw -lutil -lxo
+ CRUNCH_BUILDTOOLS+= bin/sh
+
+ # Additional options for specific programs
+@@ -128,7 +128,7 @@ CRUNCH_LIBS+= -lavl -lzpool -lzfs_core -lzfs -lnvpair -lpthread -luutil -lumem
+ # liblzma needs pthread
+ CRUNCH_LIBS+= -lpthread
+ .endif
+-CRUNCH_LIBS+= -lgeom -lbsdxml -lkiconv
++CRUNCH_LIBS+= -lgeom -lexpat -lkiconv
+ .if ${MK_OPENSSL} == "no"
+ CRUNCH_LIBS+= -lmd
+ .endif