summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 11:03:28 +0100
committerSam James <sam@gentoo.org>2023-04-18 11:03:28 +0100
commit0edb37e414acc66b9155a0f4dfeb7052aee83861 (patch)
tree6dd3f4f22ef1390e83e0de33105acc8b8f5b9f72 /sys-fs/android-file-transfer-linux/android-file-transfer-linux-4.2.ebuild
parenttoolchain.eclass: wire up modula-2 frontend support for GCC 13; disable Rust ... (diff)
downloadgentoo-0edb37e414acc66b9155a0f4dfeb7052aee83861.tar.gz
gentoo-0edb37e414acc66b9155a0f4dfeb7052aee83861.tar.bz2
gentoo-0edb37e414acc66b9155a0f4dfeb7052aee83861.zip
sys-fs/android-file-transfer-linux: sync live; fix build w/ gcc 13
Closes: https://bugs.gentoo.org/894788 Closes: https://bugs.gentoo.org/897300 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/android-file-transfer-linux/android-file-transfer-linux-4.2.ebuild')
-rw-r--r--sys-fs/android-file-transfer-linux/android-file-transfer-linux-4.2.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-4.2.ebuild b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-4.2.ebuild
index f4e8daa14678..33a9407c95aa 100644
--- a/sys-fs/android-file-transfer-linux/android-file-transfer-linux-4.2.ebuild
+++ b/sys-fs/android-file-transfer-linux/android-file-transfer-linux-4.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake python-single-r1 xdg
@@ -54,15 +54,14 @@ BDEPEND="
qt5? ( dev-qt/linguist-tools:5 )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2-gcc13.patch
+)
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
-# required to override src_prepare from xdg eclass
-src_prepare() {
- cmake_src_prepare
-}
-
src_configure() {
local mycmakeargs=(
-DBUILD_FUSE="$(usex fuse)"
@@ -73,7 +72,7 @@ src_configure() {
-DBUILD_TAGLIB="$(usex taglib)"
# Upstream recommends to keep this off as libusb is broken
-DUSB_BACKEND_LIBUSB="OFF"
- $(usex qt5 '-DDESIRED_QT_VERSION=5' '')
+ $(usev qt5 '-DDESIRED_QT_VERSION=5')
)
cmake_src_configure
}