summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-16 11:44:39 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-16 12:12:45 +0100
commit09badcd082400b18e8f6c7e41ecbf705ed1200e3 (patch)
treee6e24ddffde6bcc0d50e9572faa6956615cd2237 /sys-fs/aufs-util/aufs-util-4.0_p20151116.ebuild
parentsys-fs/aufs-headers: Bump to latest aufs release (diff)
downloadgentoo-09badcd082400b18e8f6c7e41ecbf705ed1200e3.tar.gz
gentoo-09badcd082400b18e8f6c7e41ecbf705ed1200e3.tar.bz2
gentoo-09badcd082400b18e8f6c7e41ecbf705ed1200e3.zip
sys-fs/aufs-util: Bump to latest aufs release
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-fs/aufs-util/aufs-util-4.0_p20151116.ebuild')
-rw-r--r--sys-fs/aufs-util/aufs-util-4.0_p20151116.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-fs/aufs-util/aufs-util-4.0_p20151116.ebuild b/sys-fs/aufs-util/aufs-util-4.0_p20151116.ebuild
new file mode 100644
index 000000000000..ca59ac865883
--- /dev/null
+++ b/sys-fs/aufs-util/aufs-util-4.0_p20151116.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic linux-info multilib toolchain-funcs
+
+DESCRIPTION="Utilities are always necessary for aufs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+# git archive -v --prefix=${P}/ --remote=git://git.code.sf.net/p/aufs/aufs-util aufs4.0 -o ${P}.tar
+# xz -ve9 *.tar
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ !sys-fs/aufs2
+ !<sys-fs/aufs3-3_p20130318"
+DEPEND="${RDEPEND}
+ ~sys-fs/aufs-headers-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-version.patch
+ sed \
+ -e "/LDFLAGS += -static -s/d" \
+ -e "/CFLAGS/s:-O::g" \
+ -i Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e "s:m 644 -s:m 644:g" \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -i libau/Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e '/LDLIBS/s:-lrt::g' \
+ -e '/LDLIBS/s:$: -lrt:g' \
+ -i fhsm/Makefile || die
+
+ tc-export CC AR
+ export HOSTCC=$(tc-getCC)
+}