summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-12-31 15:48:51 +0000
committerJustin Lecher <jlec@gentoo.org>2018-12-31 15:54:41 +0000
commitc5f8bcffc3004207fc43c2d8853bccd2b1533252 (patch)
treebfffa4e2b60f5fdd37d8504ee153752502d7c3fa /sys-fs/aufs-util/aufs-util-4.14_p20180709.ebuild
parentsys-fs/aufs-headers: EAPI bump (diff)
downloadgentoo-c5f8bcffc3004207fc43c2d8853bccd2b1533252.tar.gz
gentoo-c5f8bcffc3004207fc43c2d8853bccd2b1533252.tar.bz2
gentoo-c5f8bcffc3004207fc43c2d8853bccd2b1533252.zip
sys-fs/aufs-util: Bump to latest aufs release
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-fs/aufs-util/aufs-util-4.14_p20180709.ebuild')
-rw-r--r--sys-fs/aufs-util/aufs-util-4.14_p20180709.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-fs/aufs-util/aufs-util-4.14_p20180709.ebuild b/sys-fs/aufs-util/aufs-util-4.14_p20180709.ebuild
new file mode 100644
index 000000000000..4820dbcdfc70
--- /dev/null
+++ b/sys-fs/aufs-util/aufs-util-4.14_p20180709.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils flag-o-matic linux-info multilib toolchain-funcs
+
+DESCRIPTION="Utilities are always necessary for aufs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+# git archive -v --prefix=${P}/ --remote=git://git.code.sf.net/p/aufs/aufs-util aufs4.14 -o ${P}.tar
+# xz -ve9 *.tar
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ !sys-fs/aufs2
+ !<sys-fs/aufs3-3_p20130318"
+DEPEND="${RDEPEND}
+ ~sys-fs/aufs-headers-${PV}"
+
+src_prepare() {
+ sed \
+ -e "/LDFLAGS += -static -s/d" \
+ -e "/CFLAGS/s:-O::g" \
+ -i Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e "s:m 644 -s:m 644:g" \
+ -e "s:/usr/lib:/usr/$(get_libdir):g" \
+ -i libau/Makefile || die
+
+ sed \
+ -e '/LDFLAGS/s: -s::g' \
+ -e '/LDLIBS/s:-lrt::g' \
+ -e '/LDLIBS/s:$: -lrt:g' \
+ -i fhsm/Makefile || die
+
+ tc-export CC AR
+ export HOSTCC=$(tc-getCC)
+ default
+}