summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-25 21:23:56 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-25 22:05:01 -0400
commitc4895cc7013e2e7ba1745a6c3b029aa08cc5587a (patch)
tree6003922fc5b1382b2cee10c4194c71c0d1fc4909 /sys-fs/autorun
parentapp-text/aiksaurus: bump EAPI and drop eutils (diff)
downloadgentoo-c4895cc7013e2e7ba1745a6c3b029aa08cc5587a.tar.gz
gentoo-c4895cc7013e2e7ba1745a6c3b029aa08cc5587a.tar.bz2
gentoo-c4895cc7013e2e7ba1745a6c3b029aa08cc5587a.zip
sys-fs/autorun: bump EAPI and drop eutils
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-fs/autorun')
-rw-r--r--sys-fs/autorun/autorun-3.17.ebuild10
-rw-r--r--sys-fs/autorun/files/autorun-3.17-headers.patch4
2 files changed, 5 insertions, 9 deletions
diff --git a/sys-fs/autorun/autorun-3.17.ebuild b/sys-fs/autorun/autorun-3.17.ebuild
index 0b1869badd02..3fba603c6a64 100644
--- a/sys-fs/autorun/autorun-3.17.ebuild
+++ b/sys-fs/autorun/autorun-3.17.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=7
DESCRIPTION="auto cdrom mounter for the lazy user"
HOMEPAGE="http://autorun.sourceforge.net/"
@@ -19,9 +18,7 @@ DEPEND="sys-devel/gettext
app-text/xmlto
app-text/docbook-xml-dtd:4.1.2"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-headers.patch
-}
+PATCHES=( "${FILESDIR}/${P}-headers.patch" )
src_configure() {
export KDEDIR=/usr
@@ -31,5 +28,4 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
}
diff --git a/sys-fs/autorun/files/autorun-3.17-headers.patch b/sys-fs/autorun/files/autorun-3.17-headers.patch
index 642f1596b704..4fc487d656b3 100644
--- a/sys-fs/autorun/files/autorun-3.17-headers.patch
+++ b/sys-fs/autorun/files/autorun-3.17-headers.patch
@@ -1,7 +1,7 @@
https://bugs.gentoo.org/251684
---- autorun.cc
-+++ autorun.cc
+--- a/autorun.cc
++++ b/autorun.cc
@@ -90,6 +90,8 @@ char *strchr (), *strrchr ();
#include <errno.h>