summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-06-23 13:59:40 +0200
committerMichał Górny <mgorny@gentoo.org>2016-06-23 14:47:51 +0200
commit1e7a2090621d553aef2b2c5c58f902e92e0ecbba (patch)
tree3ec98f6e48cf8330f04817ea8640b14449588abb /sys-fs/bedup/bedup-0.10.1.ebuild
parentdev-util/sysdig: Bump to 0.10.1 (diff)
downloadgentoo-1e7a2090621d553aef2b2c5c58f902e92e0ecbba.tar.gz
gentoo-1e7a2090621d553aef2b2c5c58f902e92e0ecbba.tar.bz2
gentoo-1e7a2090621d553aef2b2c5c58f902e92e0ecbba.zip
sys-fs/bedup: Bump to 0.10.1
Diffstat (limited to 'sys-fs/bedup/bedup-0.10.1.ebuild')
-rw-r--r--sys-fs/bedup/bedup-0.10.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/bedup/bedup-0.10.1.ebuild b/sys-fs/bedup/bedup-0.10.1.ebuild
new file mode 100644
index 000000000000..427b35146a7b
--- /dev/null
+++ b/sys-fs/bedup/bedup-0.10.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Btrfs file de-duplication tool"
+HOMEPAGE="https://github.com/g2p/bedup"
+SRC_URI="https://github.com/g2p/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# we need btrfs-progs with includes installed.
+DEPEND=">=dev-python/cffi-0.5:=[${PYTHON_USEDEP}]
+ >=sys-fs/btrfs-progs-0.20_rc1_p358"
+RDEPEND="${DEPEND}
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.2[sqlite,${PYTHON_USEDEP}]"