summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2021-06-19 10:42:50 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-07 14:44:07 -0400
commit5ad5474983c2e84bd466d03f24c5040c8c853e92 (patch)
tree238ad07d7e8b9e4d50276ec343137d90651f1096 /sys-fs/bees/bees-9999.ebuild
parentsys-apps/systemd: add 249, drop 249_rc3 (diff)
downloadgentoo-5ad5474983c2e84bd466d03f24c5040c8c853e92.tar.gz
gentoo-5ad5474983c2e84bd466d03f24c5040c8c853e92.tar.bz2
gentoo-5ad5474983c2e84bd466d03f24c5040c8c853e92.zip
sys-fs/bees: Drop conflicting musl hack + small fixes in 9999
An upcoming musl update will add the missing function. Also: * Fix installation with eprefix * Fix style * Inherit toolchain-funcs (for tc-export) Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-fs/bees/bees-9999.ebuild')
-rw-r--r--sys-fs/bees/bees-9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/sys-fs/bees/bees-9999.ebuild b/sys-fs/bees/bees-9999.ebuild
index d656c4e6cded..7777d0ea45fd 100644
--- a/sys-fs/bees/bees-9999.ebuild
+++ b/sys-fs/bees/bees-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info systemd
+inherit linux-info systemd toolchain-funcs
DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
HOMEPAGE="https://github.com/Zygo/bees"
@@ -29,8 +29,6 @@ RDEPEND="${DEPEND}"
CONFIG_CHECK="~BTRFS_FS"
ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
-PATCHES=( "${FILESDIR}/v9999-0001-HACK-musl-does-not-define-pthread_getname_np.patch" )
-
pkg_pretend() {
if [[ ${MERGE_TYPE} != buildonly ]]; then
if kernel_is -lt 4 11; then
@@ -74,17 +72,16 @@ src_prepare() {
}
src_configure() {
+ tc-export CC CXX AR
cat >localconf <<-EOF || die
- LIBEXEC_PREFIX=/usr/libexec
- PREFIX=/usr
- LIBDIR="$(get_libdir)"
+ LIBEXEC_PREFIX="${EPREFIX}/usr/libexec"
+ PREFIX="${EPREFIX}/usr"
+ LIBDIR="${EPREFIX}/$(get_libdir)"
SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
DEFAULT_MAKE_TARGET=all
EOF
if [[ ${PV} != "9999" ]] ; then
- cat >>localconf <<-EOF || die
- BEES_VERSION=v${PV}
- EOF
+ echo BEES_VERSION=v${PV} >>localconf || die
fi
if use tools; then
echo OPTIONAL_INSTALL_TARGETS=install_tools >>localconf || die