summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-10-09 19:04:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-10-09 19:04:17 +0000
commitfdaaded8f81ad0821ae1e53ebe9e25698cb17a3b (patch)
tree4a3d112b97d59f7a45e01751ebfa70bbca6a15f3 /sys-fs/btrfs-progs/btrfs-progs-4.13.2.ebuild
parentdev-php/PEAR-Net_UserAgent_Detect: Drop old (diff)
downloadgentoo-fdaaded8f81ad0821ae1e53ebe9e25698cb17a3b.tar.gz
gentoo-fdaaded8f81ad0821ae1e53ebe9e25698cb17a3b.tar.bz2
gentoo-fdaaded8f81ad0821ae1e53ebe9e25698cb17a3b.zip
sys-fs/btrfs-progs: add USE=reiserfs for automagic depend on reiserfsprogs, bug #632092
USE=static exposed automagic dependency on libreiserfscore.a. The change adds USE=reiserfs and makes dependency and configuration explicit. While at it tweaked live ebuild (added 'm4' directory to autoconf). Reported-by: Attila Tóth Closes: https://bugs.gentoo.org/632092 Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'sys-fs/btrfs-progs/btrfs-progs-4.13.2.ebuild')
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-4.13.2.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sys-fs/btrfs-progs/btrfs-progs-4.13.2.ebuild b/sys-fs/btrfs-progs/btrfs-progs-4.13.2.ebuild
index 397d271d38c9..0dc40a977f4a 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-4.13.2.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-4.13.2.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://btrfs.wiki.kernel.org"
LICENSE="GPL-2"
SLOT="0/${libbtrfs_soname}"
-IUSE="+convert static static-libs"
+IUSE="+convert reiserfs static static-libs"
RESTRICT=test # tries to mount repared filesystems
@@ -35,6 +35,9 @@ RDEPEND="
convert? (
sys-fs/e2fsprogs:0=
sys-libs/e2fsprogs-libs:0=
+ reiserfs? (
+ sys-fs/reiserfsprogs
+ )
)
"
DEPEND="${RDEPEND}
@@ -49,6 +52,9 @@ DEPEND="${RDEPEND}
convert? (
sys-fs/e2fsprogs:0[static-libs(+)]
sys-libs/e2fsprogs-libs:0[static-libs(+)]
+ reiserfs? (
+ sys-fs/reiserfsprogs[static-libs(+)]
+ )
)
)
"
@@ -60,7 +66,7 @@ fi
src_prepare() {
default
if [[ ${PV} == 9999 ]]; then
- eautoreconf
+ AT_M4DIR=m4 eautoreconf
mkdir config || die
local automakedir="$(autotools_run_tool --at-output automake --print-libdir)"
[[ -e ${automakedir} ]] || die "Could not locate automake directory"
@@ -75,6 +81,9 @@ src_configure() {
--bindir="${EPREFIX}"/sbin
$(use_enable convert)
$(use_enable elibc_glibc backtrace)
+ # No whitespace due to 'ext2,reiserfs' being invalid
+ # for configure. TODO: Why it's not valid?
+ --with-convert=ext2$(usex reiserfs 'reiserfs' '')
)
econf "${myeconfargs[@]}"
}