summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-06 19:21:32 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-11-12 10:40:33 +0200
commit1fce2198adf40467499943f1542f557e80d85278 (patch)
treeaff9a57d2481acfcbeecfd680e0ca4bcc75c0972 /sys-fs/clamfs/clamfs-1.2.0.ebuild
parentnet-misc/seafile-client: version bump to 7.0.10 (diff)
downloadgentoo-1fce2198adf40467499943f1542f557e80d85278.tar.gz
gentoo-1fce2198adf40467499943f1542f557e80d85278.tar.bz2
gentoo-1fce2198adf40467499943f1542f557e80d85278.zip
sys-fs/clamfs: bump to 1.2.0
Closes: https://bugs.gentoo.org/732250 Closes: https://bugs.gentoo.org/737492 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/clamfs/clamfs-1.2.0.ebuild')
-rw-r--r--sys-fs/clamfs/clamfs-1.2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/clamfs/clamfs-1.2.0.ebuild b/sys-fs/clamfs/clamfs-1.2.0.ebuild
new file mode 100644
index 000000000000..af8952ff74bc
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="https://github.com/burghardt/clamfs"
+SRC_URI="https://github.com/burghardt/clamfs/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/boost-1.33
+ dev-libs/poco
+ dev-libs/rlog
+ sys-fs/fuse:3"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}