summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-02-16 00:57:02 +1300
committerSam James <sam@gentoo.org>2021-02-16 18:39:31 +0000
commitbf7ba0264955e6608e8acf2cc36694727452c5cb (patch)
treebb8748386e1d257144434b02a469bbf351fa5d06 /sys-fs/compsize/compsize-1.5.ebuild
parentwww-servers/nginx-unit: minor style changes (diff)
downloadgentoo-bf7ba0264955e6608e8acf2cc36694727452c5cb.tar.gz
gentoo-bf7ba0264955e6608e8acf2cc36694727452c5cb.tar.bz2
gentoo-bf7ba0264955e6608e8acf2cc36694727452c5cb.zip
sys-fs/compsize: bump to 1.5
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/19474 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/compsize/compsize-1.5.ebuild')
-rw-r--r--sys-fs/compsize/compsize-1.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/compsize/compsize-1.5.ebuild b/sys-fs/compsize/compsize-1.5.ebuild
new file mode 100644
index 000000000000..f00e46619d53
--- /dev/null
+++ b/sys-fs/compsize/compsize-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
+HOMEPAGE="https://github.com/kilobyte/compsize"
+
+if [[ ${PV} = 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kilobyte/compsize.git"
+else
+ SRC_URI="https://github.com/kilobyte/compsize/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+ GPL-2"
+IUSE="debug"
+SLOT="0"
+
+DEPEND="sys-fs/btrfs-progs"
+
+src_prepare() {
+ default
+ # Don't try to install a gzipped manfile during emake install
+ sed -i -e $'s/\.gz//' -e $'s/gzip.*/install \-Dm755 \$\< \$\@/' Makefile || die
+}
+
+src_configure() {
+ use debug && append-cflags -Wall -DDEBUG -g
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+ einstalldocs
+}