summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorautomorphism88 <adebeus@gmail.com>2018-03-27 10:35:21 -0700
committerPatrice Clement <monsieurp@gentoo.org>2018-04-12 00:47:17 +0200
commite5940ff991028cfdb04a615d43ee622e956899ce (patch)
treee5dd1f4d9cc27ac6131a7b0f78011e8c35702607 /sys-fs/cryfs/cryfs-9999.ebuild
parentapp-shells/dash: stable 0.5.9.1-r3 for hppa, bug #631572 (diff)
downloadgentoo-e5940ff991028cfdb04a615d43ee622e956899ce.tar.gz
gentoo-e5940ff991028cfdb04a615d43ee622e956899ce.tar.bz2
gentoo-e5940ff991028cfdb04a615d43ee622e956899ce.zip
sys-fs/cryfs: version bump to 0.9.9.
Closes: https://github.com/gentoo/gentoo/pull/7659
Diffstat (limited to 'sys-fs/cryfs/cryfs-9999.ebuild')
-rw-r--r--sys-fs/cryfs/cryfs-9999.ebuild32
1 files changed, 23 insertions, 9 deletions
diff --git a/sys-fs/cryfs/cryfs-9999.ebuild b/sys-fs/cryfs/cryfs-9999.ebuild
index 3689ed8b7db5..3e5dfe1b37b8 100644
--- a/sys-fs/cryfs/cryfs-9999.ebuild
+++ b/sys-fs/cryfs/cryfs-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-inherit cmake-utils python-any-r1
+inherit cmake-utils python-any-r1 flag-o-matic
DESCRIPTION="Encrypted FUSE filesystem that conceals metadata"
HOMEPAGE="https://www.cryfs.org/"
SLOT=0
-IUSE="libressl test update-check"
+IUSE="custom-optimization libressl test update-check"
LICENSE="LGPL-3 BSD-2 MIT"
# cryfs - LGPL-3
@@ -22,7 +22,7 @@ if [[ "${PV}" == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/cryfs/cryfs"
else
SRC_URI="https://github.com/cryfs/cryfs/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~x86"
S="${WORKDIR}"
fi
@@ -48,21 +48,26 @@ src_prepare() {
src_configure() {
# upstream restricts installing files to Release configuration
# (CMAKE_BUILD_TYPE does not affect anything else)
- local CMAKE_BUILD_TYPE=Release
- local mycmakeargs=(
+ local CMAKE_BUILD_TYPE
+ local -a mycmakeargs
+ CMAKE_BUILD_TYPE=Release
+ mycmakeargs=(
"-DBoost_USE_STATIC_LIBS=off"
"-DCRYFS_UPDATE_CHECKS=$(usex update-check)"
"-DBUILD_TESTING=$(usex test)"
)
+ use custom-optimization || append-flags -O3
cmake-utils_src_configure
}
src_test() {
- local TMPDIR="${T}"
+ local TMPDIR
+ TMPDIR="${T}"
addread /dev/fuse
addwrite /dev/fuse
- local tests_failed=()
+ local -a tests_failed
+ tests_failed=()
for i in gitversion cpp-utils parallelaccessstore blockstore blobstore fspp cryfs cryfs-cli ; do
"${BUILD_DIR}"/test/${i}/${i}-test || tests_failed+=( "${i}" )
@@ -72,7 +77,16 @@ src_test() {
if [[ -n ${tests_failed[@]} ]] ; then
eerror "The following tests failed:"
- eerror "$tests_failed[@]"
+ eerror "${tests_failed[@]}"
die "At least one test failed"
fi
}
+
+src_install() {
+ # work around upstream issue with cmake not creating install target
+ # in Makefile if we enable BUILD_TESTING
+ dobin "${BUILD_DIR}/src/cryfs-cli/cryfs"
+ gzip -cd "${BUILD_DIR}/doc/cryfs.1.gz" > "${T}/cryfs.1" || die
+ doman "${T}/cryfs.1"
+ einstalldocs
+}