summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-07 07:07:50 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-07 07:08:06 +0100
commit4b8460424bb4e111e78d6c707151904733530ff6 (patch)
treeef078abb7e9fd921f4e904cbb54beba937860927 /sys-fs/ddrescue/ddrescue-1.21-r1.ebuild
parentsys-devel/llvm: Drop CMAKE_MIN_VERSION for 3.9 (diff)
downloadgentoo-4b8460424bb4e111e78d6c707151904733530ff6.tar.gz
gentoo-4b8460424bb4e111e78d6c707151904733530ff6.tar.bz2
gentoo-4b8460424bb4e111e78d6c707151904733530ff6.zip
sys-fs/ddrescue: Revbumps to reflect some build system changes.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-fs/ddrescue/ddrescue-1.21-r1.ebuild')
-rw-r--r--sys-fs/ddrescue/ddrescue-1.21-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/ddrescue-1.21-r1.ebuild b/sys-fs/ddrescue/ddrescue-1.21-r1.ebuild
new file mode 100644
index 000000000000..00240c0a9470
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.21-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="https://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86 ~amd64-linux"
+IUSE="static"
+
+DEPEND="$(unpacker_src_uri_depends)"
+RDEPEND=""
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ dodoc ChangeLog README NEWS AUTHORS
+}