summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2017-08-14 09:57:34 +0200
committerAndreas Schuerch <nativemad@gentoo.org>2017-08-14 09:57:34 +0200
commit9e23b72f99ee1a49e72cbd4f08857da8248fc6be (patch)
tree95456401a2eb179174ae09e54c00743ceecf5870 /sys-fs/dislocker/dislocker-0.7.1-r1.ebuild
parentdev-python/colout: Remove last-rited pkg, #616330 (diff)
downloadgentoo-9e23b72f99ee1a49e72cbd4f08857da8248fc6be.tar.gz
gentoo-9e23b72f99ee1a49e72cbd4f08857da8248fc6be.tar.bz2
gentoo-9e23b72f99ee1a49e72cbd4f08857da8248fc6be.zip
sys-fs/dislocker: remove old versions, remove polarssl #618364 and newer ruby #627148
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-fs/dislocker/dislocker-0.7.1-r1.ebuild')
-rw-r--r--sys-fs/dislocker/dislocker-0.7.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-fs/dislocker/dislocker-0.7.1-r1.ebuild b/sys-fs/dislocker/dislocker-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..f0bc602be4d9
--- /dev/null
+++ b/sys-fs/dislocker/dislocker-0.7.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils cmake-utils flag-o-matic
+
+DESCRIPTION="Dislocker is used to read BitLocker encrypted partitions."
+HOMEPAGE="https://github.com/Aorimn/dislocker"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/Aorimn/dislocker.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Aorimn/dislocker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ruby"
+
+DEPEND="sys-fs/fuse:*
+ net-libs/mbedtls
+ ruby? ( || ( dev-lang/ruby:2.2 dev-lang/ruby:2.3 ) )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+# We either need to change Werror to Wno-error or remove the multiple declarations of FORTIFY_SOURCE
+# sed 's:Werror:Wno-error:g' -i "${S}/src/CMakeLists.txt" || die
+ sed 's:-D_FORTIFY_SOURCE=2::g' -i "${S}/src/CMakeLists.txt" || die
+
+ sed 's:\.\./man:'../../${P}/man':g' -i "${S}/src/CMakeLists.txt" || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_find_package ruby Ruby)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ find "${S}/man/linux" -name '*.1' -exec doman '{}' +
+ cmake-utils_src_install
+}