summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-12-31 13:22:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-12-31 13:22:40 +0100
commit35f4591df05a0748eadbefb847a5d362803b7edb (patch)
treefab6255382beae49695bfac275afdd0f589c1dbc /sys-fs/dmg2img/dmg2img-1.6.7-r1.ebuild
parentsys-fs/dmg2img: Removed old. (diff)
downloadgentoo-35f4591df05a0748eadbefb847a5d362803b7edb.tar.gz
gentoo-35f4591df05a0748eadbefb847a5d362803b7edb.tar.bz2
gentoo-35f4591df05a0748eadbefb847a5d362803b7edb.zip
sys-fs/dmg2img: Revbump to fix build against openssl-1.1
bumped to EAPI-6. Closes: https://bugs.gentoo.org/674168 Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/dmg2img/dmg2img-1.6.7-r1.ebuild')
-rw-r--r--sys-fs/dmg2img/dmg2img-1.6.7-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/dmg2img/dmg2img-1.6.7-r1.ebuild b/sys-fs/dmg2img/dmg2img-1.6.7-r1.ebuild
new file mode 100644
index 000000000000..bf3ba7ee1f50
--- /dev/null
+++ b/sys-fs/dmg2img/dmg2img-1.6.7-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
+HOMEPAGE="http://vu1tur.eu.org/tools"
+SRC_URI="http://vu1tur.eu.org/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl:0=
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-openssl11.patch #674168
+)
+
+src_prepare() {
+ default
+ sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin dmg2img vfdecrypt
+ dodoc README
+ doman vfdecrypt.1
+}