summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-26 19:56:43 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-26 21:13:55 +0100
commit51ab0816bc55ddcbb0627e640f158863897bde7d (patch)
tree7e6a4a1fc95093d42f74a6a00a7a6a410a5b72ef /sys-fs/duperemove/duperemove-0.11_beta4.ebuild
parentnet-wireless/blueman: Bump to 2.1.alpha1 (diff)
downloadgentoo-51ab0816bc55ddcbb0627e640f158863897bde7d.tar.gz
gentoo-51ab0816bc55ddcbb0627e640f158863897bde7d.tar.bz2
gentoo-51ab0816bc55ddcbb0627e640f158863897bde7d.zip
sys-fs/duperemove: Bump to 0.11.beta4
Diffstat (limited to 'sys-fs/duperemove/duperemove-0.11_beta4.ebuild')
-rw-r--r--sys-fs/duperemove/duperemove-0.11_beta4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.11_beta4.ebuild b/sys-fs/duperemove/duperemove-0.11_beta4.ebuild
new file mode 100644
index 000000000000..5eabf5cccfe7
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.11_beta4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove"
+SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz -> ${P/_/.}.tar.gz"
+
+# includes code from libbloom, xxhash (BSD-2)
+# includes code from polarssl (GPL-2+)
+LICENSE="GPL-2 GPL-2+ BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3=
+ dev-libs/glib:2="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_/.}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}