summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-02-12 11:40:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-12 11:40:28 +0100
commitb82444451fae274a0d9f4f0b7660bb23706d576e (patch)
tree60583e82d0d0f368641442ee0af382c775b7c24e /sys-fs/e2tools/e2tools-0.1.0.ebuild
parentdev-vcs/git: ppc64 stable wrt bug #702296 (diff)
downloadgentoo-b82444451fae274a0d9f4f0b7660bb23706d576e.tar.gz
gentoo-b82444451fae274a0d9f4f0b7660bb23706d576e.tar.bz2
gentoo-b82444451fae274a0d9f4f0b7660bb23706d576e.zip
sys-fs/e2tools: Bump to version 0.1.0
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/e2tools/e2tools-0.1.0.ebuild')
-rw-r--r--sys-fs/e2tools/e2tools-0.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-fs/e2tools/e2tools-0.1.0.ebuild b/sys-fs/e2tools/e2tools-0.1.0.ebuild
new file mode 100644
index 000000000000..0f866011f863
--- /dev/null
+++ b/sys-fs/e2tools/e2tools-0.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="utilities to read, write, and manipulate files in an ext2/ext3 filesystem"
+HOMEPAGE="https://github.com/ndim/e2tools"
+SRC_URI="https://github.com/e2tools/e2tools/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export CC
+ default
+}