summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-31 18:12:56 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-31 18:13:43 -0400
commit3eba4a7d03ebd38bb96bc486fa8a972cefb3bc73 (patch)
tree7954fc5ae057bf64a4fa7c813ae92759b6831794 /sys-fs/e2tools
parentsys-fs/e2tools: fix building when /bin/sh is not bash (diff)
downloadgentoo-3eba4a7d03ebd38bb96bc486fa8a972cefb3bc73.tar.gz
gentoo-3eba4a7d03ebd38bb96bc486fa8a972cefb3bc73.tar.bz2
gentoo-3eba4a7d03ebd38bb96bc486fa8a972cefb3bc73.zip
sys-fs/e2tools: set up a sane default CC
The ancient autoconf defaults to `gcc` otherwise.
Diffstat (limited to 'sys-fs/e2tools')
-rw-r--r--sys-fs/e2tools/e2tools-0.0.16.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-fs/e2tools/e2tools-0.0.16.ebuild b/sys-fs/e2tools/e2tools-0.0.16.ebuild
index 081fb974fa41..052ef631c0f7 100644
--- a/sys-fs/e2tools/e2tools-0.0.16.ebuild
+++ b/sys-fs/e2tools/e2tools-0.0.16.ebuild
@@ -4,6 +4,8 @@
EAPI="5"
+inherit toolchain-funcs
+
DESCRIPTION="utilities to read, write, and manipulate files in an ext2/ext3 filesystem"
HOMEPAGE="http://home.earthlink.net/~k_sheff/sw/e2tools/"
SRC_URI="http://home.earthlink.net/~k_sheff/sw/${PN}/${P}.tar.gz"
@@ -24,5 +26,6 @@ src_prepare() {
src_configure() {
# The configure script is ancient.
export CONFIG_SHELL="/bin/bash"
+ tc-export CC
default
}