summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-07 02:56:49 +0100
committerSam James <sam@gentoo.org>2022-06-07 02:59:09 +0100
commit3cca794d0d7256292b0be28aa333f6cf580cb0a2 (patch)
treefefca61b6c8564b80fa87c89f4b6a7b31efa491d /sys-fs/eudev/eudev-9999.ebuild
parentapp-admin/sudo: add 1.9.11 (diff)
downloadgentoo-3cca794d0d7256292b0be28aa333f6cf580cb0a2.tar.gz
gentoo-3cca794d0d7256292b0be28aa333f6cf580cb0a2.tar.bz2
gentoo-3cca794d0d7256292b0be28aa333f6cf580cb0a2.zip
sys-fs/eudev: add 3.2.12_pre1 (unkeyworded)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/eudev/eudev-9999.ebuild')
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild69
1 files changed, 39 insertions, 30 deletions
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index a4edb4657be9..18823816ad13 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -1,32 +1,36 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
KV_MIN=2.6.39
-inherit autotools linux-info multilib-minimal toolchain-funcs
+inherit autotools linux-info multilib-minimal toolchain-funcs udev
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/eudev-project/eudev.git"
inherit git-r3
else
- SRC_URI="https://github.com/eudev-project/eudev/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ MY_PV=${PV/_pre/-pre}
+ SRC_URI="https://github.com/eudev-project/eudev/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_PV}
+
+ if [[ ${PV} != *_pre* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ fi
fi
DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
-HOMEPAGE="https://github.com/gentoo/eudev"
+HOMEPAGE="https://github.com/eudev-project/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
-IUSE="+kmod introspection rule-generator selinux static-libs test"
+IUSE="+kmod rule-generator selinux static-libs test"
RESTRICT="!test? ( test )"
DEPEND=">=sys-apps/util-linux-2.20
>=sys-kernel/linux-headers-${KV_MIN}
virtual/libcrypt:=
- introspection? ( >=dev-libs/gobject-introspection-1.38 )
kmod? ( >=sys-apps/kmod-16 )
selinux? ( >=sys-libs/libselinux-2.1.9 )
!sys-apps/gentoo-systemd-integration
@@ -42,8 +46,10 @@ RDEPEND="${DEPEND}
BDEPEND="dev-util/gperf
virtual/os-headers
virtual/pkgconfig
- >=sys-devel/make-3.82-r4
- test? ( app-text/tree dev-lang/perl )"
+ test? (
+ app-text/tree
+ dev-lang/perl
+ )"
PDEPEND=">=sys-fs/udev-init-scripts-26"
MULTILIB_WRAPPED_HEADERS=(
@@ -52,7 +58,7 @@ MULTILIB_WRAPPED_HEADERS=(
pkg_pretend() {
ewarn
- ewarn "As of 2013-01-29, ${P} provides the new interface renaming functionality,"
+ ewarn "As of 2013-01-29, ${PN} provides the new interface renaming functionality,"
ewarn "as described in the URL below:"
ewarn "https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
ewarn
@@ -79,11 +85,12 @@ pkg_setup() {
}
src_prepare() {
- # change rules back to group uucp instead of dialout for now
+ default
+
+ # Change rules back to group uucp instead of dialout for now
sed -e 's/GROUP="dialout"/GROUP="uucp"/' -i rules/*.rules \
|| die "failed to change group dialout to uucp"
- default
eautoreconf
}
@@ -93,14 +100,13 @@ multilib_src_configure() {
# bug #502950
export cc_cv_CFLAGS__flto=no
- # Keep sorted by ./configure --help and only pass --disable flags
- # when *required* to avoid external deps or unnecessary compile
- local econf_args
- econf_args=(
+ local myeconfargs=(
ac_cv_search_cap_init=
ac_cv_header_sys_capability_h=yes
+
DBUS_CFLAGS=' '
DBUS_LIBS=' '
+
--with-rootprefix=
--with-rootrundir=/run
--exec-prefix="${EPREFIX}"
@@ -114,19 +120,17 @@ multilib_src_configure() {
# Only build libudev for non-native_abi, and only install it to libdir,
# that means all options only apply to native_abi
- if multilib_is_native_abi; then
- econf_args+=(
+ if multilib_is_native_abi ; then
+ myeconfargs+=(
--with-rootlibdir="${EPREFIX}"/$(get_libdir)
- $(use_enable introspection)
$(use_enable kmod)
$(use_enable static-libs static)
$(use_enable selinux)
$(use_enable rule-generator)
)
else
- econf_args+=(
+ myeconfargs+=(
--disable-static
- --disable-introspection
--disable-kmod
--disable-selinux
--disable-rule-generator
@@ -134,11 +138,11 @@ multilib_src_configure() {
)
fi
- ECONF_SOURCE="${S}" econf "${econf_args[@]}"
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_compile() {
- if multilib_is_native_abi; then
+ if multilib_is_native_abi ; then
emake
else
emake -C src/shared
@@ -147,22 +151,21 @@ multilib_src_compile() {
}
multilib_src_test() {
- # make sandbox get out of the way
- # these are safe because there is a fake root filesystem put in place,
+ # Make sandbox get out of the way.
+ # These are safe because there is a fake root filesystem put in place,
# but sandbox seems to evaluate the paths of the test i/o instead of the
- # paths of the actual i/o that results.
- # also only test for native abi
- if multilib_is_native_abi; then
+ # paths of the actual i/o that results. Also only test for native abi
+ if multilib_is_native_abi ; then
addread /sys
addwrite /dev
addwrite /run
- default_src_test
+ default
fi
}
multilib_src_install() {
- if multilib_is_native_abi; then
+ if multilib_is_native_abi ; then
emake DESTDIR="${D}" install
else
emake -C src/libudev DESTDIR="${D}" install
@@ -178,7 +181,13 @@ multilib_src_install_all() {
use rule-generator && doinitd "${FILESDIR}"/udev-postmount
}
+pkg_postrm() {
+ udev_reload
+}
+
pkg_postinst() {
+ udev_reload
+
mkdir -p "${EROOT}"/run
# "losetup -f" is confused if there is an empty /dev/loop/, Bug #338766