summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2024-01-07 19:22:27 -0800
committerGöktürk Yüksek <gokturk@gentoo.org>2024-01-07 19:33:37 -0800
commit6df45df54e7fd8e2c9151d333b5404dc88b9e96e (patch)
treee26dda1147063a19469a1174fefe5abc57c07635 /sys-fs/ext4magic/ext4magic-0.3.2-r2.ebuild
parentapp-admin/gopass-summon-provider: drop 1.15.8, 1.15.10 (diff)
downloadgentoo-6df45df54e7fd8e2c9151d333b5404dc88b9e96e.tar.gz
gentoo-6df45df54e7fd8e2c9151d333b5404dc88b9e96e.tar.bz2
gentoo-6df45df54e7fd8e2c9151d333b5404dc88b9e96e.zip
sys-fs/ext4magic: fix building with musl #716136
Also update EAPI 6 -> 8, and update LICENSES. Closes: https://bugs.gentoo.org/716136 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'sys-fs/ext4magic/ext4magic-0.3.2-r2.ebuild')
-rw-r--r--sys-fs/ext4magic/ext4magic-0.3.2-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/ext4magic/ext4magic-0.3.2-r2.ebuild b/sys-fs/ext4magic/ext4magic-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..1ddc9bc13dec
--- /dev/null
+++ b/sys-fs/ext4magic/ext4magic-0.3.2-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Tool for recovery of deleted or overwritten files on ext3/ext4 filesystems"
+HOMEPAGE="https://sourceforge.net/projects/ext4magic/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2 FSFAP GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug +expert-mode file-attr"
+
+RDEPEND="app-arch/bzip2
+ >=sys-apps/file-5.04
+ sys-apps/util-linux
+ >=sys-fs/e2fsprogs-1.41.9
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.2-sysmacros.patch
+ "${FILESDIR}"/${PN}-0.3.2-i_dir_acl.patch
+ "${FILESDIR}"/${PN}-0.3.2-fix-sys-types-h.patch
+)
+
+src_configure() {
+ # build-system incorrectly recognizes '--disable-feature' options as enabled!
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(usex debug '--enable-debug-magic' '') \
+ $(usex expert-mode '--enable-expert-mode' '') \
+ $(usex file-attr '--enable-file-attr' '')
+}