summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2020-08-22 12:57:10 +0200
committerDaniel Pielmeier <billie@gentoo.org>2020-08-22 12:57:10 +0200
commit17051aac5bec795d157c75967cd02965949aa057 (patch)
tree6731e15d3235c9a6a3175986deae130297f23598 /sys-fs/fatsort/fatsort-1.6.3.622.ebuild
parentmedia-libs/lvtk: py3 + fixed homepage (diff)
downloadgentoo-17051aac5bec795d157c75967cd02965949aa057.tar.gz
gentoo-17051aac5bec795d157c75967cd02965949aa057.tar.bz2
gentoo-17051aac5bec795d157c75967cd02965949aa057.zip
sys-fs/fatsort: Version bump to fatsort-1.6.3.622.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'sys-fs/fatsort/fatsort-1.6.3.622.ebuild')
-rw-r--r--sys-fs/fatsort/fatsort-1.6.3.622.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/fatsort/fatsort-1.6.3.622.ebuild b/sys-fs/fatsort/fatsort-1.6.3.622.ebuild
new file mode 100644
index 000000000000..28d6fc9100bc
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-1.6.3.622.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players"
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ sed -i -e 's|/usr/local|/usr|g' \
+ $(find ./ -name Makefile) || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ DESTDIR="${D}" man
+}
+
+src_test() {
+ # Tests require root permissions and mounting filesystems which does
+ # not work inside the ebuild environment
+ true
+}