summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2023-03-20 21:57:48 +0100
committerDaniel Pielmeier <billie@gentoo.org>2023-03-20 21:57:48 +0100
commit35239b32e220422400b211fd2a6d6c84fea64b69 (patch)
treee5a1d78aeb7fd6b9da31a821f7c7e8b3abfe6319 /sys-fs/fatsort/fatsort-1.6.5.640.ebuild
parentdev-ada/VSS: add gcc_12 (diff)
downloadgentoo-35239b32e220422400b211fd2a6d6c84fea64b69.tar.gz
gentoo-35239b32e220422400b211fd2a6d6c84fea64b69.tar.bz2
gentoo-35239b32e220422400b211fd2a6d6c84fea64b69.zip
sys-fs/fatsort: add 1.6.5.640
Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'sys-fs/fatsort/fatsort-1.6.5.640.ebuild')
-rw-r--r--sys-fs/fatsort/fatsort-1.6.5.640.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/fatsort/fatsort-1.6.5.640.ebuild b/sys-fs/fatsort/fatsort-1.6.5.640.ebuild
new file mode 100644
index 000000000000..d318bb6ffdff
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-1.6.5.640.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players"
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ sed -i -e 's|/usr/local|/usr|g' \
+ $(find ./ -name Makefile || die) || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ man
+}
+
+src_test() {
+ # Tests require root permissions and mounting filesystems which does
+ # not work inside the ebuild environment
+ true
+}