summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-23 13:24:52 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-23 14:27:49 -0600
commitae53d785d0fe6de9fc90f8727e187e348321daf7 (patch)
treef72fe51d69c961fa3c85ae4d092f0b92a0c891b5 /sys-fs/fuse-common/fuse-common-3.4.1.ebuild
parentapp-misc/dateutils: remove old (diff)
downloadgentoo-ae53d785d0fe6de9fc90f8727e187e348321daf7.tar.gz
gentoo-ae53d785d0fe6de9fc90f8727e187e348321daf7.tar.bz2
gentoo-ae53d785d0fe6de9fc90f8727e187e348321daf7.zip
sys-fs/fuse-common: version bump to 3.4.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-fs/fuse-common/fuse-common-3.4.1.ebuild')
-rw-r--r--sys-fs/fuse-common/fuse-common-3.4.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/fuse-common/fuse-common-3.4.1.ebuild b/sys-fs/fuse-common/fuse-common-3.4.1.ebuild
new file mode 100644
index 000000000000..1bee8df8257a
--- /dev/null
+++ b/sys-fs/fuse-common/fuse-common-3.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit udev
+
+DESCRIPTION="Common files for multiple slots of sys-fs/fuse"
+HOMEPAGE="https://github.com/libfuse/libfuse"
+SRC_URI="https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="!<sys-fs/fuse-2.9.7-r1:0"
+
+S=${WORKDIR}/fuse-${PV}
+
+src_install() {
+ udev_newrules util/udev.rules 99-fuse.rules
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ insinto /etc
+ doins util/fuse.conf
+}