summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2016-12-03 13:34:21 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2016-12-03 13:34:41 +0000
commitac717914076575fd86ac66dc8348d19951137d29 (patch)
tree259b3006f1d83b5404c289ac4e7d2284cb48eec3 /sys-fs/fuse-zip/fuse-zip-0.4.2.ebuild
parentgames-util/glbsp: remove unused patch (diff)
downloadgentoo-ac717914076575fd86ac66dc8348d19951137d29.tar.gz
gentoo-ac717914076575fd86ac66dc8348d19951137d29.tar.bz2
gentoo-ac717914076575fd86ac66dc8348d19951137d29.zip
sys-fs/fuse-zip: Version bump. Remove old
Gentoo-Bug: 601066 Package-Manager: portage-2.3.2
Diffstat (limited to 'sys-fs/fuse-zip/fuse-zip-0.4.2.ebuild')
-rw-r--r--sys-fs/fuse-zip/fuse-zip-0.4.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/fuse-zip/fuse-zip-0.4.2.ebuild b/sys-fs/fuse-zip/fuse-zip-0.4.2.ebuild
new file mode 100644
index 000000000000..16553b2623a6
--- /dev/null
+++ b/sys-fs/fuse-zip/fuse-zip-0.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives"
+HOMEPAGE="https://bitbucket.org/agalanin/fuse-zip"
+SRC_URI="https://bitbucket.org/agalanin/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libzip-0.11.2:=
+ >=sys-fs/fuse-2.7:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ # Fix strip than installing fuse-zip
+ sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
+ #enable parallel build
+ sed -i -e "s:make :\$\(MAKE\) :" Makefile || die "sed failed"
+ # Fix prefix
+ sed -i -e "s:^prefix=.*:prefix=/usr:" Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}"
+}