summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-02-03 16:59:55 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-03 17:02:46 +0100
commitca5f6f9bf6a0c5086394c54ee4e52e6658c97f70 (patch)
tree068c7567d7bcd42407d7f0ce90ae16c24370db3f /sys-fs/inotify-tools/inotify-tools-3.20.2.2.ebuild
parentsys-fs/inotify-tools: Removed old (diff)
downloadgentoo-ca5f6f9bf6a0c5086394c54ee4e52e6658c97f70.tar.gz
gentoo-ca5f6f9bf6a0c5086394c54ee4e52e6658c97f70.tar.bz2
gentoo-ca5f6f9bf6a0c5086394c54ee4e52e6658c97f70.zip
sys-fs/inotify-tools: Bump to version 3.20.2.2
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/inotify-tools/inotify-tools-3.20.2.2.ebuild')
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.20.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/inotify-tools-3.20.2.2.ebuild b/sys-fs/inotify-tools/inotify-tools-3.20.2.2.ebuild
new file mode 100644
index 000000000000..391f17cbf861
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.20.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/inotify-tools/inotify-tools"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}/html
+ $(use_enable doc doxygen)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" \( -name '*.a*' -o -name '*.la' \) -delete || die
+}