summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-29 12:53:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-29 13:22:37 -0400
commit26182e7ab5f7af2be41774b98905855fe251b7bf (patch)
treee7769e0643d25eb547b2333a20e580b116abe6fb /sys-fs/inotify-tools
parentsys-fs/inotify-tools: drop 3.22.1.0 (diff)
downloadgentoo-26182e7ab5f7af2be41774b98905855fe251b7bf.tar.gz
gentoo-26182e7ab5f7af2be41774b98905855fe251b7bf.tar.bz2
gentoo-26182e7ab5f7af2be41774b98905855fe251b7bf.zip
sys-fs/inotify-tools: fix build with musl
Closes: https://bugs.gentoo.org/831976 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/files/inotify-tools-3.22.6.0-musl.patch26
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild4
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/files/inotify-tools-3.22.6.0-musl.patch b/sys-fs/inotify-tools/files/inotify-tools-3.22.6.0-musl.patch
new file mode 100644
index 000000000000..435adc2e797a
--- /dev/null
+++ b/sys-fs/inotify-tools/files/inotify-tools-3.22.6.0-musl.patch
@@ -0,0 +1,26 @@
+Former fix[1] for musl that got reverted[2] for possibly(?) wrong
+reasons[3]. Should be harmless to include here until sorted out.
+https://bugs.gentoo.org/831976
+
+[1] https://github.com/inotify-tools/inotify-tools/commit/b7889c8d
+[2] https://github.com/inotify-tools/inotify-tools/commit/cbab7c0b
+[3] https://github.com/inotify-tools/inotify-tools/issues/155
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 3 Jan 2022 04:42:50 -0800
+Subject: [PATCH] libinotifytools: Bridge differences between musl/glibc/kernel
+ fnotify.h (#154)
+--- a/libinotifytools/src/inotifytools.c
++++ b/libinotifytools/src/inotifytools.c
+@@ -54,6 +54,12 @@ struct fanotify_event_fid {
+ struct fanotify_event_info_fid info;
+ struct file_handle handle;
+ };
++
++#ifndef __GLIBC__
++#define val __val
++#define __kernel_fsid_t fsid_t
++#endif
++
+ #endif
+
+ /**
diff --git a/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild b/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild
index 2d25f84ae71b..6a270595ec4e 100644
--- a/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild
+++ b/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild
@@ -16,6 +16,10 @@ IUSE="doc"
BDEPEND="doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
src_prepare() {
default