summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-01-21 18:42:31 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-01-21 18:44:10 +0100
commitc38c1d6235ef1b765a8e74a0d8826f75c3717789 (patch)
treeba82f26e53da67580de3da18612c1ae577a0489c /sys-fs/inotify-tools
parentmedia-gfx/gnome-font-viewer: fix build with meson 0.61 (diff)
downloadgentoo-c38c1d6235ef1b765a8e74a0d8826f75c3717789.tar.gz
gentoo-c38c1d6235ef1b765a8e74a0d8826f75c3717789.tar.bz2
gentoo-c38c1d6235ef1b765a8e74a0d8826f75c3717789.zip
sys-fs/inotify-tools: Bump to version 3.22.1.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/Manifest1
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.22.1.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/Manifest b/sys-fs/inotify-tools/Manifest
index b95d58c1a022..8c4a6f3d9ee8 100644
--- a/sys-fs/inotify-tools/Manifest
+++ b/sys-fs/inotify-tools/Manifest
@@ -2,3 +2,4 @@ DIST inotify-tools-3.20.11.0.tar.gz 84827 BLAKE2B 1d3e25c4e213c9c6da74575677a6dc
DIST inotify-tools-3.20.2.2.tar.gz 81006 BLAKE2B 7dd29985f68096fe2146a3ad84d619b3d1238b0db25eeb125f2fe9591fa678078351f00c7e09b526cf2251e4736201d5625ff0e477523cae370a307ccb667730 SHA512 72d6fdcc216d8083cd384c71c02dc8e800d3a9702613568b3c571f704aee3d42bf084c52f2141c9afb8d28e8b87ebb6391ed3d825b3d664ed51c552debeb1881
DIST inotify-tools-3.21.9.5.tar.gz 91711 BLAKE2B cf6575cdd445a823c8272a9f8394ed241af1cc729784ec363c9dac6cd3c5cf37856076e88d389669d9da768b899e7ecb64c997e25b42cd5fccc2ebbbf145b273 SHA512 d0ae070f4fa3ea261913bba4ed6edf865aa8ddb9235cf5e967d11f54168a78d92739a5110a1afbdedbe3e6f0cbaf395883e2d47a182c9e6847986da184a52a97
DIST inotify-tools-3.21.9.6.tar.gz 91668 BLAKE2B cfb279d69e650b275af03052f4f76522670b7a563aa4e81bd5883b3ff825ecb70382cd4a5d48a9eb50b59930685a60b59a17376958d111d129c61fbced47a6bb SHA512 206eeebfd948499d81e6666b153cd7d9b05df618291fd3ada6479251b0773ce629c19f73117442a9093f028e294c5ba2dfa0aa4cf711510284ab7cad657da21c
+DIST inotify-tools-3.22.1.0.tar.gz 92922 BLAKE2B 42558ca62f79e2bdf5a6071334a05cee826ec00b0666b1c0971af64d769eb7852cbcd8d6e630f88af68f26f5607ca4ef94ec832fbe2e89d42182120aac4896ce SHA512 53317147af4803b69603839c010a2b0b3fa527f0e32b08126f24805600728c0a9570b2a3d94bf987f0b9a4bfbe7207b5faa9337f0d7add91b062e68de4245548
diff --git a/sys-fs/inotify-tools/inotify-tools-3.22.1.0.ebuild b/sys-fs/inotify-tools/inotify-tools-3.22.1.0.ebuild
new file mode 100644
index 000000000000..2d25f84ae71b
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.22.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/inotify-tools/inotify-tools"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~riscv ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ # Remove -Werror from CFLAGS (#745069)
+ find -name "Makefile.am" -print0 \
+ | xargs --null sed 's@ -Werror@@' -i || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ local myeconfargs=(
+ --disable-static
+ --docdir='$(datarootdir)'/doc/${PF}/html
+ $(use_enable doc doxygen)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}