summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-06-07 12:48:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2022-06-08 09:27:41 +0200
commitdfb97f896b0c756a009cf8f81f3e852c39cdda75 (patch)
tree2df3877d916fed19f8fb44f53d78eeb77c1429cd /sys-fs/inotify-tools
parentnet-im/pidgin: Bump to version 2.14.10 (diff)
downloadgentoo-dfb97f896b0c756a009cf8f81f3e852c39cdda75.tar.gz
gentoo-dfb97f896b0c756a009cf8f81f3e852c39cdda75.tar.bz2
gentoo-dfb97f896b0c756a009cf8f81f3e852c39cdda75.zip
sys-fs/inotify-tools: Bump to version 3.22.6.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/Manifest1
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/Manifest b/sys-fs/inotify-tools/Manifest
index 55c4240f8e1b..9ef891ba3324 100644
--- a/sys-fs/inotify-tools/Manifest
+++ b/sys-fs/inotify-tools/Manifest
@@ -1,3 +1,4 @@
DIST inotify-tools-3.20.2.2.tar.gz 81006 BLAKE2B 7dd29985f68096fe2146a3ad84d619b3d1238b0db25eeb125f2fe9591fa678078351f00c7e09b526cf2251e4736201d5625ff0e477523cae370a307ccb667730 SHA512 72d6fdcc216d8083cd384c71c02dc8e800d3a9702613568b3c571f704aee3d42bf084c52f2141c9afb8d28e8b87ebb6391ed3d825b3d664ed51c552debeb1881
DIST inotify-tools-3.21.9.6.tar.gz 91668 BLAKE2B cfb279d69e650b275af03052f4f76522670b7a563aa4e81bd5883b3ff825ecb70382cd4a5d48a9eb50b59930685a60b59a17376958d111d129c61fbced47a6bb SHA512 206eeebfd948499d81e6666b153cd7d9b05df618291fd3ada6479251b0773ce629c19f73117442a9093f028e294c5ba2dfa0aa4cf711510284ab7cad657da21c
DIST inotify-tools-3.22.1.0.tar.gz 92922 BLAKE2B 42558ca62f79e2bdf5a6071334a05cee826ec00b0666b1c0971af64d769eb7852cbcd8d6e630f88af68f26f5607ca4ef94ec832fbe2e89d42182120aac4896ce SHA512 53317147af4803b69603839c010a2b0b3fa527f0e32b08126f24805600728c0a9570b2a3d94bf987f0b9a4bfbe7207b5faa9337f0d7add91b062e68de4245548
+DIST inotify-tools-3.22.6.0.tar.gz 92918 BLAKE2B 601d3ac6896e445d297a04498c63df4f81c59699ba2d5b2eee2e8c499332913ce2783d13c9906d577ff0b6d7ef91ca826d48b01674adeb3d3569dfc1fbc0df63 SHA512 cda445add4b9d80b70eff9189ed50d05f4b5593a755159d0354431166c6fe6fdb33f7bf37fd50bc09aad3ed0a6e3763b9c74f65e554400f2596b8d492f1d0a21
diff --git a/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild b/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild
new file mode 100644
index 000000000000..2d25f84ae71b
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.22.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/inotify-tools/inotify-tools"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~riscv ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ # Remove -Werror from CFLAGS (#745069)
+ find -name "Makefile.am" -print0 \
+ | xargs --null sed 's@ -Werror@@' -i || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ local myeconfargs=(
+ --disable-static
+ --docdir='$(datarootdir)'/doc/${PF}/html
+ $(use_enable doc doxygen)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}