summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-20 19:30:32 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-20 19:50:17 +0200
commit6435b76a0b8ba107feb568c74e0be3b449bba31f (patch)
treef81971223259e5e3872619ec0eea5de0b27942af /sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
parentdev-perl/Class-Singleton: Stabilize 1.500.0-r1 arm64, #738212 (diff)
downloadgentoo-6435b76a0b8ba107feb568c74e0be3b449bba31f.tar.gz
gentoo-6435b76a0b8ba107feb568c74e0be3b449bba31f.tar.bz2
gentoo-6435b76a0b8ba107feb568c74e0be3b449bba31f.zip
sys-fs/jfsutils: rev bump
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild')
-rw-r--r--sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild b/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
new file mode 100644
index 000000000000..9d17529ffecb
--- /dev/null
+++ b/sys-fs/jfsutils/jfsutils-1.1.15-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="IBM's Journaling Filesystem (JFS) Utilities"
+HOMEPAGE="http://jfs.sourceforge.net/"
+SRC_URI="http://jfs.sourceforge.net/project/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 s390 ~sparc x86"
+IUSE="static"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linux-headers.patch #448844
+ epatch "${FILESDIR}"/${P}-sysmacros.patch #580056
+}
+
+src_configure() {
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ use static && append-ldflags -static
+ econf --sbindir=/sbin
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"/sbin/{mkfs,fsck}.jfs || die
+ dosym /sbin/jfs_mkfs /sbin/mkfs.jfs
+ dosym /sbin/jfs_fsck /sbin/fsck.jfs
+}