summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/lessfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/lessfs')
-rw-r--r--sys-fs/lessfs/Manifest2
-rw-r--r--sys-fs/lessfs/lessfs-1.5.13.ebuild49
-rw-r--r--sys-fs/lessfs/lessfs-1.7.0.ebuild51
-rw-r--r--sys-fs/lessfs/metadata.xml19
4 files changed, 121 insertions, 0 deletions
diff --git a/sys-fs/lessfs/Manifest b/sys-fs/lessfs/Manifest
new file mode 100644
index 000000000000..b1fdfadf4a10
--- /dev/null
+++ b/sys-fs/lessfs/Manifest
@@ -0,0 +1,2 @@
+DIST lessfs-1.5.13.tar.gz 506221 SHA256 eba0ec05d4586d8741776dc96ca9369a9544fb8b8998d5c692da331ddf4ba7f2 SHA512 7143b7e1df8e059184d003be6519cac323fa035a6d9005b4e007504328d58624232ff9a494ecf11d445977f9138e7c41492d7fd30721065e5293927f85585604 WHIRLPOOL 2ef56b0057178678e280b65d458aa6c216c16e84b9524be8bfe66c2da0778f4ca89dd991dc4644f31fbb432621c4e08575d8191ccfc3f8197834a5096440d813
+DIST lessfs-1.7.0.tar.gz 514667 SHA256 d5782ab88ca79bf8f7d790d440f30e3979ec8ecad2a8eae75d33260bfadc8711 SHA512 a868b28159fbcd2e7672607d46e3007c7b959bd8c8880b6c98cdab6c61fd104ac222e156f543c2b3e9f9d9fe2f1879c2988ee80605946f03b646481e7c6f15d1 WHIRLPOOL bee790252b5a0ce5b71621c65e5454334ef55f003e55c7b7a96acafec11281606c50820e7d3ed68675255953b2f479881d329e351e79684a057a6e6433036ee8
diff --git a/sys-fs/lessfs/lessfs-1.5.13.ebuild b/sys-fs/lessfs/lessfs-1.5.13.ebuild
new file mode 100644
index 000000000000..310c1711e43d
--- /dev/null
+++ b/sys-fs/lessfs/lessfs-1.5.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit readme.gentoo
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A high performance inline data deduplicating filesystem"
+HOMEPAGE="http://www.lessfs.com"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="berkdb crypt debug filelog memtrace lzo"
+
+DEPEND="berkdb? ( sys-libs/db )
+ >=dev-db/tokyocabinet-1.4.42
+ app-crypt/mhash
+ >=sys-fs/fuse-2.8.0
+ crypt? ( dev-libs/openssl )
+ lzo? ( dev-libs/lzo )"
+
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOC_CONTENTS="Default configuration file: /etc/${PN}.cfg.
+ If your host is a client consult the following configuration
+ file: /usr/share/doc/${PF}/${PN}.cfg-slave.*"
+
+src_configure() {
+ econf \
+ $(use_enable debug) $(use_enable debug lckdebug) \
+ $(use_enable filelog) $(use_with crypt crypto) \
+ $(use_with lzo) $(use_enable memtrace) \
+ $(use_with berkdb berkeleydb)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog FAQ README.*
+ insinto /etc
+ newins examples/lessfs.cfg-master ${PN}.cfg
+ dodoc examples/lessfs.* etc/lessfs.*
+ readme.gentoo_create_doc
+}
diff --git a/sys-fs/lessfs/lessfs-1.7.0.ebuild b/sys-fs/lessfs/lessfs-1.7.0.ebuild
new file mode 100644
index 000000000000..99fe01fe5e4b
--- /dev/null
+++ b/sys-fs/lessfs/lessfs-1.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit readme.gentoo
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A high performance inline data deduplicating filesystem"
+HOMEPAGE="http://www.lessfs.com"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="berkdb crypt debug filelog memtrace lzo snappy"
+
+DEPEND="berkdb? ( sys-libs/db )
+ crypt? ( dev-libs/openssl )
+ lzo? ( dev-libs/lzo )
+ snappy? ( app-arch/snappy )
+ >=dev-db/tokyocabinet-1.4.42
+ app-crypt/mhash
+ >=sys-fs/fuse-2.8.0"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOC_CONTENTS="Default configuration file: /etc/${PN}.cfg.
+ If your host is a client consult the following configuration
+ file: /usr/share/doc/${PF}/${PN}.cfg-slave.*"
+
+src_configure() {
+ econf \
+ $(use_enable debug) $(use_enable debug lckdebug) \
+ $(use_enable filelog) $(use_with crypt crypto) \
+ $(use_with lzo) $(use_enable memtrace) \
+ $(use_with berkdb berkeleydb) \
+ $(use_with snappy)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog FAQ README.*
+ insinto /etc
+ newins examples/lessfs.cfg-master ${PN}.cfg
+ dodoc examples/lessfs.* etc/lessfs.*
+ readme.gentoo_create_doc
+}
diff --git a/sys-fs/lessfs/metadata.xml b/sys-fs/lessfs/metadata.xml
new file mode 100644
index 000000000000..e6b229aec935
--- /dev/null
+++ b/sys-fs/lessfs/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ </maintainer>
+ <use>
+ <flag name="filelog">Enable the ability to log to a file instead of syslog</flag>
+ <flag name="memtrace">Enable leefs to create a report regarding the memory allocation. This feature should be used for debugging purposes to avoid performance degradation</flag>
+ <flag name="snappy">Enable snappy compression using the <pkg>app-arch/snappy</pkg> library</flag>
+ </use>
+ <longdescription lang="en">
+Data deduplication (often called “intelligent compression” or “single-instance storage”) is a method of reducing storage needs by eliminating redundant data. Data deduplication is often used for backup purposes and for virtual machine image storage. lessfs can determine if data is redundant by calculating a unique (192 bit) tiger hash of each block of data that is written. When lessfs has determined that a block of data needs to be stored it first compresses the block with LZO or QUICKLZ compression. The combination of these two techniques results in a very high overall compression rate for many types of data. Multimedia files like mp3, avi or jpg files can not be compressed by lessfs when they are only stored once on the filesystem.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">lessfs</remote-id>
+ </upstream>
+</pkgmetadata>