summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-06-24 12:23:48 -0400
committerMike Gilbert <floppym@gentoo.org>2022-06-24 12:23:48 -0400
commiteb8a99321f0bef37ad1b9a39876b61c9dec33150 (patch)
tree62fddf085ef3f63190899a236a7d665e0c34ac05 /sys-fs/lvm2
parentdev-python/myst_parser: Enable pypy3 (diff)
downloadgentoo-eb8a99321f0bef37ad1b9a39876b61c9dec33150.tar.gz
gentoo-eb8a99321f0bef37ad1b9a39876b61c9dec33150.tar.bz2
gentoo-eb8a99321f0bef37ad1b9a39876b61c9dec33150.zip
sys-fs/lvm2: pass SYSTEMD_GENERATOR_DIR to make install
Passing systemdutildir does not work because it is a configure variable, not a make variable. Closes: https://bugs.gentoo.org/840577 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.188-r3.ebuild (renamed from sys-fs/lvm2/lvm2-2.02.188-r2.ebuild)2
-rw-r--r--sys-fs/lvm2/lvm2-2.03.14-r2.ebuild (renamed from sys-fs/lvm2/lvm2-2.03.14-r1.ebuild)2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.188-r3.ebuild
index a3e76755f1d5..50111c5fabb3 100644
--- a/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.188-r3.ebuild
@@ -210,7 +210,7 @@ src_install() {
local inst
local INSTALL_TARGETS=( install install_tmpfiles_configuration )
# install systemd related files only when requested, bug #522430
- use systemd && INSTALL_TARGETS+=( systemdutildir="$(systemd_get_utildir)" install_systemd_units install_systemd_generators )
+ use systemd && INSTALL_TARGETS+=( SYSTEMD_GENERATOR_DIR="$(systemd_get_systemgeneratordir)" install_systemd_units install_systemd_generators )
use device-mapper-only && INSTALL_TARGETS=( install_device-mapper )
emake V=1 DESTDIR="${D}" "${INSTALL_TARGETS[@]}"
diff --git a/sys-fs/lvm2/lvm2-2.03.14-r1.ebuild b/sys-fs/lvm2/lvm2-2.03.14-r2.ebuild
index 66b2184868ed..2da81764efe4 100644
--- a/sys-fs/lvm2/lvm2-2.03.14-r1.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.14-r2.ebuild
@@ -212,7 +212,7 @@ src_install() {
local inst
local INSTALL_TARGETS=( install install_tmpfiles_configuration )
# install systemd related files only when requested, bug #522430
- use systemd && INSTALL_TARGETS+=( systemdutildir="$(systemd_get_utildir)" install_systemd_units install_systemd_generators )
+ use systemd && INSTALL_TARGETS+=( SYSTEMD_GENERATOR_DIR="$(systemd_get_systemgeneratordir)" install_systemd_units install_systemd_generators )
use device-mapper-only && INSTALL_TARGETS=( install_device-mapper )
emake V=1 DESTDIR="${D}" "${INSTALL_TARGETS[@]}"