summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2016-10-11 03:38:34 +0000
committerErik Mackdanz <stasibear@gentoo.org>2016-10-11 03:38:34 +0000
commitff7322fad07652b900900d7a0edb1e95892951bf (patch)
tree62c2308017d62f5a080abfe1984bd2d5888b5004 /sys-fs/lxcfs/lxcfs-2.0.4.ebuild
parentwww-client/chromium: beta channel bump (54.0.2840.50) (diff)
downloadgentoo-ff7322fad07652b900900d7a0edb1e95892951bf.tar.gz
gentoo-ff7322fad07652b900900d7a0edb1e95892951bf.tar.bz2
gentoo-ff7322fad07652b900900d7a0edb1e95892951bf.zip
sys-fs/lxcfs: Bump to 2.0.4
Package-Manager: portage-2.3.1
Diffstat (limited to 'sys-fs/lxcfs/lxcfs-2.0.4.ebuild')
-rw-r--r--sys-fs/lxcfs/lxcfs-2.0.4.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/lxcfs-2.0.4.ebuild b/sys-fs/lxcfs/lxcfs-2.0.4.ebuild
new file mode 100644
index 000000000000..39c20c4ee084
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-2.0.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit systemd vcs-snapshot versionator
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lxc/lxcfs.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ # e.g. upstream is 2.0.0.beta2, we want 2.0.0_beta2
+ UPSTREAM_PV=$(replace_version_separator 3 '.' )
+ SRC_URI="https://github.com/lxc/lxcfs/archive/${PN}-${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+IUSE="pam"
+
+# Omit all dbus. Upstream appears to require it because systemd, but
+# lxcfs makes no direct use of dbus.
+RDEPEND="
+ dev-libs/glib:2
+ sys-fs/fuse
+ virtual/pam
+"
+DEPEND="
+ sys-apps/help2man
+ ${RDEPEND}
+"
+PATCHES="${FILESDIR}/${P}-fusermount-path.patch"
+
+src_prepare() {
+ default
+ ./bootstrap.sh || die "Failed to bootstrap configure files"
+}
+
+src_configure() {
+ use pam || pamflag="--with-pamdir=none"
+
+ # Without the localstatedir the filesystem isn't mounted correctly
+ econf --localstatedir=/var ${pamflag}
+}
+
+# Test suite fails for me
+# src_test() {
+# emake tests
+# tests/main.sh || die "Tests failed"
+# }
+
+src_install() {
+ default
+ dodir /var/lib/lxcfs
+ newinitd "${FILESDIR}"/${P}.initd lxcfs
+ systemd_dounit config/init/systemd/lxcfs.service
+}
+
+pkg_preinst() {
+ # In an upgrade situation merging /var/lib/lxcfs (an empty dir)
+ # fails because that is a live mountpoint when the service is
+ # running. It's unnecessary anyway so skip the action.
+ [[ -d ${ROOT}/var/lib/lxcfs ]] && rm -rf ${D}/var
+}