summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2022-11-10 09:18:53 +0600
committerJakov Smolić <jsmolic@gentoo.org>2022-11-25 02:23:44 +0100
commitbd38b6de2c77dd7e36a127b16ff495ed7d5a6e2e (patch)
tree771d7020e5d11d83a6de314a27bb6b7af26e12b5 /sys-fs/ncdu/ncdu-1.17.ebuild
parentsec-keys/openpgp-keys-yorhel: new package, add 20221110 (diff)
downloadgentoo-bd38b6de2c77dd7e36a127b16ff495ed7d5a6e2e.tar.gz
gentoo-bd38b6de2c77dd7e36a127b16ff495ed7d5a6e2e.tar.bz2
gentoo-bd38b6de2c77dd7e36a127b16ff495ed7d5a6e2e.zip
sys-fs/ncdu: add verify-sig integration
Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sys-fs/ncdu/ncdu-1.17.ebuild')
-rw-r--r--sys-fs/ncdu/ncdu-1.17.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sys-fs/ncdu/ncdu-1.17.ebuild b/sys-fs/ncdu/ncdu-1.17.ebuild
index 69646594d053..49b7d752a4e9 100644
--- a/sys-fs/ncdu/ncdu-1.17.ebuild
+++ b/sys-fs/ncdu/ncdu-1.17.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
+
+inherit verify-sig
DESCRIPTION="NCurses Disk Usage"
HOMEPAGE="https://dev.yorhel.nl/ncdu/"
-SRC_URI="https://dev.yorhel.nl/download/${P}.tar.gz"
+SRC_URI="
+ https://dev.yorhel.nl/download/${P}.tar.gz
+ verify-sig? ( https://dev.yorhel.nl/download/${P}.tar.gz.asc )
+"
LICENSE="MIT"
SLOT="0"
@@ -13,4 +18,9 @@ KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~riscv ~sparc x86 ~amd64-linux
DEPEND="sys-libs/ncurses:=[unicode(+)]"
RDEPEND="${DEPEND}"
-BDEPEND="virtual/pkgconfig"
+BDEPEND="
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-yorhel )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/yoranheling.asc