summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2023-03-09 23:01:20 +0600
committerSam James <sam@gentoo.org>2023-03-11 17:15:10 +0000
commite4707343c9b2c5c1bfc27d09a6025b191fc7093a (patch)
treefb394cb55d7e73389549c8d88ea806cad12b5026 /sys-fs/ncdu/ncdu-2.2.2-r1.ebuild
parentdev-java/miglayout: add github upstream metadata (diff)
downloadgentoo-e4707343c9b2c5c1bfc27d09a6025b191fc7093a.tar.gz
gentoo-e4707343c9b2c5c1bfc27d09a6025b191fc7093a.tar.bz2
gentoo-e4707343c9b2c5c1bfc27d09a6025b191fc7093a.zip
sys-fs/ncdu: create and use zig variable in makefile
Big thanks to Florian Schmaus <flow@gentoo.org> for creating and upstreaming this patch! I guess I contributed too much entropy and problems to testing branch today :% Closes: https://bugs.gentoo.org/900547 Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/30023 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/ncdu/ncdu-2.2.2-r1.ebuild')
-rw-r--r--sys-fs/ncdu/ncdu-2.2.2-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sys-fs/ncdu/ncdu-2.2.2-r1.ebuild b/sys-fs/ncdu/ncdu-2.2.2-r1.ebuild
index b8f45c71bf2c..74c745fa8f11 100644
--- a/sys-fs/ncdu/ncdu-2.2.2-r1.ebuild
+++ b/sys-fs/ncdu/ncdu-2.2.2-r1.ebuild
@@ -30,6 +30,10 @@ BDEPEND="
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/yoranheling.asc
+PATCHES=(
+ "${FILESDIR}/${P}-makefile-add-zig-variable.patch"
+)
+
# see https://github.com/ziglang/zig/issues/3382
# For now, Zig doesn't support CFLAGS/LDFLAGS/etc.
QA_FLAGS_IGNORED="usr/bin/ncdu"
@@ -120,9 +124,9 @@ src_unpack() {
default
}
-src_compile() {
- ezig build -Drelease-fast
- edo pod2man --center "ncdu manual" --release "ncdu-${PV}" ncdu.pod >ncdu.1
+src_configure() {
+ zig-set_EZIG
+ export ZIG=${EZIG}
}
src_test() {