summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-09-13 22:30:24 +0200
committerDavid Seifert <soap@gentoo.org>2021-09-13 22:30:24 +0200
commit648d8cc3e049337918ad899faae1e46273619e73 (patch)
treea252adb07dc223ee15fa686746064c524149ea4c /sys-fs/nilfs-utils/nilfs-utils-2.2.2-r1.ebuild
parentsys-fs/extundelete: e2fsprogs-libs → e2fsprogs (diff)
downloadgentoo-648d8cc3e049337918ad899faae1e46273619e73.tar.gz
gentoo-648d8cc3e049337918ad899faae1e46273619e73.tar.bz2
gentoo-648d8cc3e049337918ad899faae1e46273619e73.zip
sys-fs/nilfs-utils: e2fsprogs-libs → e2fsprogs
Bug: https://bugs.gentoo.org/806875 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs/nilfs-utils/nilfs-utils-2.2.2-r1.ebuild')
-rw-r--r--sys-fs/nilfs-utils/nilfs-utils-2.2.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/nilfs-utils/nilfs-utils-2.2.2-r1.ebuild b/sys-fs/nilfs-utils/nilfs-utils-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..1a9f4b558ab0
--- /dev/null
+++ b/sys-fs/nilfs-utils/nilfs-utils-2.2.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="A New Implementation of a Log-structured File System for Linux"
+HOMEPAGE="http://nilfs.sourceforge.net/"
+SRC_URI="http://nilfs.sourceforge.net/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ sys-fs/e2fsprogs
+ sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+
+CONFIG_CHECK="~POSIX_MQUEUE"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --libdir="${EPREFIX}"/$(get_libdir) \
+ --enable-libmount
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}