summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/progsreiserfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/progsreiserfs')
-rw-r--r--sys-fs/progsreiserfs/Manifest1
-rw-r--r--sys-fs/progsreiserfs/files/progsreiserfs-0.3.1_rc8-autotools.patch13
-rw-r--r--sys-fs/progsreiserfs/metadata.xml9
-rw-r--r--sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild60
4 files changed, 83 insertions, 0 deletions
diff --git a/sys-fs/progsreiserfs/Manifest b/sys-fs/progsreiserfs/Manifest
new file mode 100644
index 000000000000..661fbbdbc4a4
--- /dev/null
+++ b/sys-fs/progsreiserfs/Manifest
@@ -0,0 +1 @@
+DIST progsreiserfs-0.3.1-rc8.tar.gz 399279 SHA256 1473899a21df0679a32ebde5a35c158468a7e51a0cb6fd89d77c42bfde9b6399 SHA512 65266ab5a598b2073e6893da6554bdfe43796be3bd608eb7c4f687c3ef6ed395ce67def49b62d2b3705dfdeb38bd5f5d1c91fec6ad7323788d490058b015c26d WHIRLPOOL 2afe87ef74d7bbbd012b5dd141663291222e8bf22ae318ac217e38f0af90f7524beb15362ebbc001f3998f14a555b10586e09a5cb412c105dce6b791cd2ee2fa
diff --git a/sys-fs/progsreiserfs/files/progsreiserfs-0.3.1_rc8-autotools.patch b/sys-fs/progsreiserfs/files/progsreiserfs-0.3.1_rc8-autotools.patch
new file mode 100644
index 000000000000..4a0753f4f09b
--- /dev/null
+++ b/sys-fs/progsreiserfs/files/progsreiserfs-0.3.1_rc8-autotools.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/442226
+
+--- progsreiserfs.m4
++++ progsreiserfs.m4
+@@ -10,7 +10,7 @@
+ dnl Adds the required libraries to $REISERFS_LIBS and does an
+ dnl AC_SUBST(REISERFS_LIBS)
+
+-AC_DEFUN(AC_CHECK_LIBREISERFS,
++AC_DEFUN([AC_CHECK_LIBREISERFS],
+ [
+
+ dnl save LIBS
diff --git a/sys-fs/progsreiserfs/metadata.xml b/sys-fs/progsreiserfs/metadata.xml
new file mode 100644
index 000000000000..07c910b18ad9
--- /dev/null
+++ b/sys-fs/progsreiserfs/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+ <description>Maintainer as part of base-system work. Assign bugs to base-system.</description>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild b/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
new file mode 100644
index 000000000000..a699539e568f
--- /dev/null
+++ b/sys-fs/progsreiserfs/progsreiserfs-0.3.1_rc8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic libtool
+
+MY_P=${PN}-${PV/_/-}
+
+DESCRIPTION="Library for accessing and manipulating reiserfs partitions"
+HOMEPAGE="http://reiserfs.linux.kiev.ua/"
+SRC_URI="http://reiserfs.linux.kiev.ua/snapshots/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86"
+IUSE="debug examples nls static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/util-linux
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotools.patch
+
+ elibtoolize
+}
+
+src_configure() {
+ filter-lfs-flags
+
+ econf \
+ $(use_enable static-libs static) \
+ --disable-Werror \
+ $(use_enable nls) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ docinto examples
+ dodoc demos/*.c
+ fi
+
+ rm -r "${ED}"/usr/{sbin,share/man} || die
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ ewarn "progsreiserfs has been proven dangerous in the past, generating bad"
+ ewarn "partitions and destroying data on resize/cpfs operations."
+ ewarn "Because of this, we do NOT provide their binaries, but only their"
+ ewarn "libraries instead, as these are needed for other applications."
+}